[SOLVED] Change the password of mumble server



How can I change the superuser password ?

Thanks in advance

Check this : http://wiki.mumble.info/wiki/Murmurguide#Setting_SuperUser_Password

For linux

./murmur.x86 [-ini <path>] -supw Password_of_your_choice

Can you please tell where is murmur.86 and what is the path in the yuno server ?

Just hit

`murmurd -ini /etc/mumble-server.ini -supw <new_password>`

Executing this command do this

murmurd -ini /etc/mumble-server.ini -supw password_for_example_123
> exit
> ^C

Is your ini file at /etc/mumble-server.ini ?

Yes its at /etc/mumble-server.ini

try to put your password between double quotes

I tried doing the command with double quotes,but same result.

Try re-installing mumble-server if you can

I uninstalled the mumble-server and then reinstalled it.
It gives me error while installing.

Executing script...
-su: -c: line 0: unexpected EOF while looking for matching ``'
-su: -c: line 1: syntax error: unexpected end of file
Error: Installation failed

The mumble-server is still the in service interface despite of the uninstall of the application.

Solved: The password should not have ` in it.

Tried this. The output I get is:

admin@myserver:~$ sudo murmurd -supw MY_PASSWORD
<W>2021-12-12 19:52:58.005 SSL: OpenSSL version is 'OpenSSL 1.1.1d  10 Sep 2019'
<W>2021-12-12 19:52:58.005 Initializing settings from /etc/mumble-server.ini (basepath /etc)
<W>2021-12-12 19:52:58.304 MetaParams: TLS cipher preference is "TLS_AES_256_GCM_SHA384:TLS_CHACHA20_POLY1305_SHA256:TLS_AES_128_GCM_SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA:AES256-SHA:AES128-SHA"
<C>2021-12-12 19:52:58.305 Successfully switched to uid 123
<W>2021-12-12 19:52:58.339 ServerDB: Opened SQLite database /var/lib/mumble-server/mumble-server.sqlite
<W>2021-12-12 19:52:58.339 ServerDB: Using SQLite's default rollback journal.
<F>2021-12-12 19:52:58.369 Superuser password set on server 1

But when I try to login to the server I get:


Recently, I had to change the SuperUser password and none of the commands described above and in the official documentation worked. It appears that the installation procedure of Yunohost’s Mumble Server app has changed and differs from the standard way.

After trying to understand how the app was installed, I came up with the following command, that worked for me (with Mumble 1.3.4~ynh1, running on a Yunohost server This command has to be run as root :

# /usr/sbin/murmurd -ini /var/www/mumbleserver/mumble-server.ini -supw YourStrongPassword