[SOLVED]Can't upload files to seafile since yunohost 4.1 update

Hello everyone, this is my first post and I hope I won’t be too much of a noob.

My YunoHost server

Hardware: Raspberry Pi 3B+ at home
**YunoHost version:4.1.6
I have access to my server : Through SSH | through the webadmin

Description of my issue

I can’t upload nor download files from my seafile anymore since the yunohost 4.1.6 update I did three or four days ago. I can still delete files from the web interface though.
My client log specifies this: http-tx-mgr.c(1221): Parse response failed: ‘[’ or ‘{’ expected near ‘<’.
My SERVICE_URL is set to mydomain/seafile and FILE_SERVER_ROOT to mydomain/seafhttp.
I didn’t modify any conf file since I’ve updated yunohost and none of the users can upload files.

Hope it’ll be enough information.


Eeeeeh wokay, naively investigate with :

grep -nr -C4 'sea' /etc/ssowat/conf.json*

Here’s the result of the command (I just replaced my actual domain name by MYDOMAIN and the users names by USERS):

/etc/ssowat/conf.json-79-            "users": [
/etc/ssowat/conf.json-80-                "MYUSERNAME"
/etc/ssowat/conf.json-81-            ]
/etc/ssowat/conf.json-82-        }, 
/etc/ssowat/conf.json:83:        "seafile.main": {
/etc/ssowat/conf.json-84-            "auth_header": true, 
/etc/ssowat/conf.json-85-            "label": "Seafile", 
/etc/ssowat/conf.json-86-            "public": true, 
/etc/ssowat/conf.json-87-            "show_tile": true, 
/etc/ssowat/conf.json-88-            "uris": [
/etc/ssowat/conf.json:89:                "MYDOMAIN/seafile"
/etc/ssowat/conf.json-90-            ], 
/etc/ssowat/conf.json-91-            "users": [
/etc/ssowat/conf.json.persistent-5-            "label": "Custom permissions - skipped", 
/etc/ssowat/conf.json.persistent-6-            "public": true, 
/etc/ssowat/conf.json.persistent-7-            "show_tile": false, 
/etc/ssowat/conf.json.persistent-8-            "uris": [
/etc/ssowat/conf.json.persistent:9:                "/seafhttp", 
/etc/ssowat/conf.json.persistent:10:                "/seafdav", 
/etc/ssowat/conf.json.persistent:11:                "/seafhttp", 
/etc/ssowat/conf.json.persistent:12:                "/seafdav", 
/etc/ssowat/conf.json.persistent:13:                "/seafhttp", 
/etc/ssowat/conf.json.persistent:14:                "/seafdav", 
/etc/ssowat/conf.json.persistent:15:                "/seafhttp", 
/etc/ssowat/conf.json.persistent:16:                "/seafdav", 
/etc/ssowat/conf.json.persistent:17:                "/seafhttp", 
/etc/ssowat/conf.json.persistent:18:                "/seafdav", 
/etc/ssowat/conf.json.persistent:19:                "/seafhttp", 
/etc/ssowat/conf.json.persistent:20:                "/seafdav", 
/etc/ssowat/conf.json.persistent:21:                "/seafhttp", 
/etc/ssowat/conf.json.persistent:22:                "/seafdav", 
/etc/ssowat/conf.json.persistent:23:                "/seafhttp", 
/etc/ssowat/conf.json.persistent:24:                "/seafdav"
/etc/ssowat/conf.json.persistent-25-            ], 
/etc/ssowat/conf.json.persistent-26-            "users": []
/etc/ssowat/conf.json.persistent-27-        }
/etc/ssowat/conf.json.persistent-28-    }, 
/etc/ssowat/conf.json.persistent.save:1:{"skipped_urls": ["/seafhttp", "/seafdav", "/seafhttp", "/seafdav"], "redirected_urls": {"b

I just wanted to say that my seafile also broke since the update. I cannot upload nor download files from my seafile anymore, also the client cannot sync my files.
Thanks @okayk for opening this topic!

Hmmmmokay I think those should in fact start with “your.domain.tld” like this :

"uris": [

(also possibly remove the duplicated line)

Can you try to apply this with nano /etc/ssowat/conf.json.persistent ?


This solution worked for me!
Thanks a lot!

Yes it worked for me too, thanks a lot!

It worked for me too, thanks!

I like when I have an issue and I don’t even need to ask for a fix - thanks @Aleks it worked for me too!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.