[solved] Cannot use emails... but I receive apps notifications ?:)

Hi,
thank you for Yunohost.

I cannot use email.
It seems to me the DNS settings are OK
RoundCube works correctly (issue solved: https://frama.link/3y9hVNEz, Thank you @Aleks)
but I cannot receive and send emails.

When sending a message, I have got this message:

Error (553): Failed to add recipient “Jose.relland@gmail.com” (5.7.1 <jrd@bacasable.eu>: Sender address rejected: not owned by user jrd).

Please, note the very weird thing (for me).
In this jrd@bacasable.eu account, I receive correctly WordPress notifications…
I received this morning the WP update notification :).

Thank you for your time.

Best Regards from France, José

Soo can you confirm that jrd@bacasable.eu is either the main address of the user jrd as defined in YunoHost - or one of its aliases ? (You can see this in the info about the user in the webadmin).

Also can you confirm that bacasable.eu is one of the domains of your Yunohost instance and not some external domain ?

Hi @Aleks
Thank you for your feedback…

So OK @Aleks good point :slight_smile:

Point 1. “Alors”, as we say in French, I was thinking that jrd@bacasable.eu was the (first and) main address…
But I noted that another address: jrelland@bascasable.eu, had these alias root@b… postmaster@…

Does that mean that jrelland@bascasable.eu is the true “admin user”?
Not jrd@b…?

I configured RoundCube for jrelland@bacasable.eu… I tried to send a mail… same error message!

SMTP Error (553): Failed to add recipient "jose.relland@gmail.com" (5.7.1 jrelland@basasable.eu: Sender address rejected: not owned by user jrelland).

Please, note when I set my email address in RoundCube, I mention the user address (not jrelland@localhost)


Point 2. bacasable.eu is the unique domain declared in Yunohost :slight_smile:

And it works perfectly : https://bacasable.eu/yunohost/sso/

Thank you for your time and considération.

Best Regards From France, José

Uuuuh but now it’s talking about user jrelland (c.f. the end of the message) instead of jrd as in the initial post ? So you’re connected through a different user ?

To try to summarize how it should be :

  • when you’re creating a user in yunohost, you are asked to define the email address of the user
  • usually the standard choice is, considering that the user is named sacha, to simply put sacha@maindomain.tld
  • the very first user automatically has additional aliases created for it, namely root@, admin@, and also postmaster and another I forgot about (?)
  • if you chose for example s@maindomain.tld instead of sacha@maindomain.tld, then trying to send an email as sacha@maindomain.tld apriori wont work, stating that the address is not owned by user sacha … only s@maindomain.tld (and other aliases) are…
  • if you want, you may still later add sacha@maindomain.tld as an alias for user sacha and that should fix the issue

Hopefully that clarifies thing … That’s probably counterintuitive that sacha@maindomain.tld is not automatically owner by sacha, maybe we should just force this as a default email when creating a user, idk

Hi @Aleks,
Sorry if I’m a bit confusing with my answers :frowning:

Thank you for your clear feedback.
Let me detail:

In my case everything seems ok…

  • User declaration
  • RoundCube settings

I have uninstalled admin’s RoundCube (jrelland] and reinstal it. No error message :slight_smile:

On jrelland@bacasable.eu, I can:

  • Receive a message
  • Send a message to a unexisting address, I have the right message “unknown recipiend”
  • receive message from root@, postmaster@… (I do not know how to send a message as root@…)

But, when I send a message,
a) I have the right message “email sent” with the green stick
b) I have the message in the Sent box
but the user do not receive the message (even after 30 mn)!

The same pour l’utilisateur jrd (adresse ; jrd.bas@bacasable.eu).

Let me share with you my DNS… OVH VPS and domain

First, I just found out an error message!

Le déploiement de votre zone est effectué. Cependant les anomalies suivantes ont été détectées :

  1. zone bacasable.eu/IN: _xmpp-server._tcp.bacasable.eu/SRV ‘bacasble.eu’ (out of zone) has no addresses records (A or AAAA)
    However,
    _xmpp-client._tcp.bacasable.eu. 3600 SRV 0 5 5222 bacasable.eu.
    _xmpp-server._tcp.bacasable.eu. 3600 SRV 0 5 5269 bacasble.eu
    seems ok regarding the settings proposed by Yunohost https://yunohost.org/#/dns_config

except perhaps “_xmpp-server._tcp.bacasable.eu.” but I cannot set “_xmpp-server._tcp.” with the OVH tool.

Settings for emails

Thank you for your time and considération.

Doesn’t sound like an issue with DNS settings - the initial error message (Sender address rejected: not owned by user) really suggests it’s related to the ownership between user and adresses …

So can you try to clarify, when doing your test :

  • which user you connect with to the roundcube interface (should be the user you logged in with on the yunohost sso, if connecting through the SSO)
  • which address appears in the “From” field when writing the email at the top
  • what’s the destination address

The destination address shouldn’t matter so much … my guess is that the issue is coming from an inconsistency between the user you are connected with and the address in the “From” field (the sented address)

Hence the error message : Sender address rejected, not owner by user xxx …

Thank you for this quick feedback.

Please, note I didn’t get more this message.
Now, the unique issue is that the receiver does not receive the message.

Thank you for your time.
José from France.

Hmokay, so if that’s GMail, then I would guess that’s related to your emails being flagged as spam somehow, and GMail dropping them silently … Which may therefore be related to DNS setting.

Maybe can you try to test your setup with mail-tester.com and see if there’s an obvious issue ?

1 Like

Ha !!!
Je suis un idiot de ne pas y avoir pensé !

Effectivement, tous les mails sont dans la junk box !
Donc… tout marche bien,

Merci pour cette formidable application qui permet de tout faire avec vraiment peu de connaissance en admin !

I’m a fool !
I even did not think about junk box!

for this addresses, I select them as no-spam… and now I receive the emails! :slight_smile:
Now I understand why i did not receive my notifications from OpenSondage :wink:

YNH is a fantastic application which allows doing so many things without being a sysadmin!

Thank you again.

José From france

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.