[SOLVED] Calibre-web installation fails due to rust and cryptography problems


My YunoHost server

Hardware: Raspberry Pi at home with VPN
YunoHost version:
I have access to my server : Through SSH, through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: Calibre-web 0.96.19~ynh8

Description of my issue

Trying to install the app.
Getting this log with errors: https://paste.yunohost.org/raw/exihusejoq
Updated pip and installed rust
Seems like something about packages on setuptools, which I wouldn’t know how to manage…
Or like rust not being on path? That too I wouldn’t know how to solve.

Building wheel for cryptography (pyproject.toml) did not run successfully.
Installing 'cryptography.hazmat.bindings._rust' as data is deprecated, please list it in `packages`.
error: can't find Rust compiler
ERROR: Could not build wheels for cryptography, which is required to install pyproject.toml-based projects

Thanks a loooot

I guess this is the same error as in Building wheel for cryptography (pyproject.toml): finished with status 'error' · Issue #106 · YunoHost-Apps/calibreweb_ynh · GitHub
Some packages dependencies are messed up in the pip repo, and you have to wait until the mainteners (of pip, of the package, I don’t know) sort it out before being able to install. Usually, wait for a few days and it will solve itself.
Sorry I cannot help more, but if anyone has a better understanding of how it works, I would be glad.

Yes apparently that’s it, various problems with building cryptography for ARM32 devices… Let’s hope it gets fixed soon! Thanks for your answer

Hey. I’ve posed the question on the calibre-web github (here) and they say updating pip and installing cargo should be the solution.

I’ve done everything of this already. Pip and the likes (rust, cargo) are all installed and updated in my /home/user/.local/... directory, which is correctly on PATH too.

So I’m not getting it… Does calibre-web for ynh install on directories which don’t have access to those programs? Or look for those programs in other places?
The errors are still the same as above. I think this is a specific problem for ARM architectures

So the pip version is already the last one (at least from the debian repo, I used to get it from https://bootstrap.pypa.io/get-pip.py, but I removed it following other issues that were caused by the everchanging version )
I the program you installed are in YOUR user home directory, I don’t think the root user (which does the install) will be able to access it.

EDIT: By reareading your answer I get that you’re actually saying that having downloaded programs on my ynh user path (only option I have) this won’t have effect. So only thing is to wait that pip and rust are somehow integrated or updated somewhere upstream maybe

Nono, I meant on my ynh, through ssh.
Well, apparently no solution yet, will continue trying.
What strikes me is that it says that pip and rust are “n/a”, while I did download them and can regularly find them on ynh. So for now it’s a mistery.
Thanks anyway for following :hugs:

Hey! Just to say that actually, finally, by upgrading yunohost with today’s updates the installtion magically worked!!
Thanks again for following and the patience (and contributing/packaging) !!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.