[SOLVED] Baikal problems since 0.9.3-ynh3 upgrade

My YunoHost server

Hardware: computer

YunoHost version: 11.2.4
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: baikal v0.9.2~ynh2

Description of my issue

Baikal is not accessible on 0.9.3-ynh3 and deletion and restore does not work.
It seems related to the PHP 8.0 configuration
Here is the log file:

Could it be linked to that?

Hi @aoz,

Thank for your reply, I saw your previous mention to this post on Github on the parallel topic of this forum.
I dont have the skills to fix it as per described in this post.
Do you know what would be the way to make it work again?

In my case baikal is uninstalled, and I tried to restore the previous one (0.9.2 before update) without success. And as it seems the problem comes from the PHP configuration.

Additionally, the fix will come from upstream, so it might take time, and I cannot use this service, which is central to my everyday life. :frowning:

In fact, I’m afraid the post I linked above is related to the bug of not being able to connect to Baikal, not to its installation on yunohost.

If it’s really urgent to get back your baikal while waiting on the fix to come, I found a way to retore it from 0.9.3 ynh2 (I think it’s what you meant?) :
all is done in bash ssh to your server:

summary : change the php version from 8.2 down to 8.0 in the apps/baikal/settings/scripts/_common.sh file in the backup and restore from it

  • ssh to your server and create a working folder :
    mkdir tempWork
  • get the backup from your archive folder :
    cp /home/yunohost.backup/archive/baikal-pre-upgradeX.tar /home/your_user/tempWork | where X is the latest one from before the update
  • make an extra folder and cd into it :
    mkdir tempExtract then cd tempExtract
  • extract the tar folder :
    tar -x ../baikal-pre-upgradeX.tar
  • edit the file _common.sh in apps/baikal/settings/scripts/ with your fav editor :
    sudo vim apps/baikal/settings/scripts/_common.sh
  • change the php version to 8.0 (in place of 8.2). Save and quit
  • repack the tar with a different name :
    sudo tar -cf baikal-pre-upgradeX-mod.tar *
  • copy it to the archive folder :
    sudo cp /home/your_user/tempWork/tempExtract/baikal-pre-upgradeX-mod.tar /home/yunohost.backup/archive/
  • copy the json from the other archive :
    sudo cp /home/yunohost.backup/archive/baikal-pre-upgradeX.info.json /home/yunohost.backup/archive/baikal-pre-upgradeX-mod.info.json
  • restore the archive : sudo yunohost backup restore baikal-pre-upgradeX-mod --app

This forces the use of phpfpm 8.0, That worked for me, hope it can be usefull

1 Like

New version in testing:

  • revert php version to 8.1
  • package version 2

if you are willing to test:

sudo yunohost app install https://github.com/YunoHost-Apps/baikal_ynh/tree/testing --debug
sudo yunohost app upgrade baikal -u https://github.com/YunoHost-Apps/baikal_ynh/tree/testing --debug

Dear @flatrongraad,

Thank you for the detailed process. I concur, it worked and I was able to restore the service.

Is it something we should consider for the app catalog, to have some sort of php version freeze or php version downgrade capabilities for certain important apps?

Thanks again.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.