[Solved] "401: User not logged in" after upgrading NextCloud

My YunoHost server

Hardware: VPS bought online, via Hetzner.de
YunoHost version: 4.2.4
I have access to my server : Through SSH, through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

After upgrading an old YunoHost install and then upgrading NextCloud (all the way from 13.0 to 20.0.8) I am having problems using the NextCloud web interface. I have rebooted multiple times, ensured all migrations have run, and upgraded all system packages via the web interface.

The NextCloud web interface works for changing settings, and seeing the new Dashboard. However, accessing files causes problems. The main file list shows, but very soon after in the top right the message “Problem loading page, reloading in 5 seconds” appears. After 5 seconds, I get booted back to the login page.

If I access the Network page of the browser Developer Tools, I see that when NextCloud starts loading some subpages (e.g. previews for files) those web accesses return status 401 and the content is

{message: "Current user is not logged in"}

Looking at the logs section of NextCloud’s settings I can see this message:

/var/www/nextcloud/apps/user_ldap/templates/part.wizard-server.php - line 10:

OC\Log\ErrorHandler::onError(8, "Undefined index: s01", "/var/www/ne ... p", 10, { 0: "And 65 ... }})

Unfortunately I don’t know where to find the actual logfile for more information.

Here’s what I’ve tried so far to diagnose the problem:

  • tried multiple browsers
  • tried multiple YunoHost users
  • rebooted the server a few times
  • rescanned all files with occ tool

I have no more ideas what to do. Help is very much appreciated. Many thanks.

Ooookay, I think I solved it. I had to delete all cookies for the domain where NextCloud was being served from.

Sorry for the trouble.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.