[SnappyMail] Lightweight webmail

Please try to reboot your server.
Clear your browser cache.
Relog on your snappymail user account.

On my case, it has not appear after setting it up, but after this precedure (not sure if everything is needed, but it’s always better to test :wink: )

Petit souci “L’authentification a échoué” ici : Snappymail - "L'authentification a échoué", envois mail impossible

Suite à la restauration d’une sauvegarde sur installation propre RPiOS + yuno, Snappymail m’affiche :

[302] The following PHP extensions are not available in your PHP configuration!


cf fil dédié.

Des propositions de pistes à creuser ?
Merci !


Ce matin suite à la dernière mise à jour de snappymail, j’ai ceci dans mon navigateur web :

[301] Your PHP version is 32bit, 64bit is required!

C’est assez fâcheux !

Si quelqu’un a une idée lumineuse, je lui en serais grandement reconnaissant !

Since the last version there is a check to see if PHP is running on 64-bit:

  • Check PHP_INT_SIZE if SnappyMail runs on 64bit

You can check if your PHP is running in 64 or 32-bit with this command.

php -r "echo (PHP_INT_SIZE == 4 ? '32 bit' : '64 bit').PHP_EOL;" && php -i | grep Thread

I don’t know how to upgrade PHP from 32 to 64 bit, but if you want help, you need to provide more details about your server configuration.

Thank you for your answer ! My whole system is 32 bit… I used the backup restore tool and it works again.

i use it on a raspberry pi 3 … only 32bits …
is there a way to keep it up to date ? or i’ll need to change the pi itself ?

after a little search, i think the only option is to make a full save of the system and reinstall it on 64bit version … will try next time

With the last Snappymail version you should be able to install to a 32bit arch again.

tried today, can’t update, yuno says that update can only be done on x64 systems …

that is because the fix is still in testing… will be merged soon


keep us up to date ! ty

I tried today, successfully :wink:

Hey, my mobile Firefox is not able to autowrite login/pass in the index page.
Am I alone with this bug ?

Cannot login Admin Panel after upgrade recently… version: 2.29.1~ynh1, Authentication failed. Am I alone?

Same problem. I had to backup. I don’t recommand to install this last upgrade !

I have problems too with this version:

I think that I missed the 2.29.1~ynh1 update, but I’m now running the 2.29.1~ynh2 with no problem. Maybe it was fixed in that version ?

Yes, now i can access snappymail user interface with 2.29.1~ynh2 version, but still not login admin panel.

I can now login by restoring the old /var/www/snappymail/app/data/data/default/configs/application.ini file.

Finally i keep the new application.ini file:

Disallowed Sec-Fetch Dest: document Mode: navigate Site: same-site User: true

looks like having the mail in a subdomain generates this

disabling mail for that subdomain

The configuration file '/var/www/.well-known/xxxxx/autoconfig/mail/config-v1.1.xml' has been manually modified and will not be updated
Configuration updated for 'postfix'
Configuration updated for 'dovecot'
postmap: fatal: open /etc/postfix/sni: No such file or directory
Could not run script: /usr/share/yunohost/hooks/conf_regen/19-postfix
Config updated as expected