SMTP error Vaultwarden invite user

My YunoHost server

Hardware: VPS bought online
YunoHost version: (stable)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi all,

This is a long message, I know. Just trying to provide all the data I can.

The issue is with Vaultwarden version 1.29.1~ynh3.

These are logs of the console when I’m simply logged in Vaultwarden without having made any changes.
This is a screenshot of those logs, but uncollapsed.

Steps to reproduce

Log in latest version 1.29.1~ynh3 of Vaultwarde, go to Organisations > Members > Invite members > Input email > Click Save > Should not work and get an error.

Stuff I tried

  • I did look on the forum, found nothing particular to my issue, especially that I consider it’s to do with the new version of Vaultwarden.
  • I tried to invite a new user on Vaultwarden and I got the following message:
    • After the failed attempt to invite user, that user does show in the list of user in the Vaultwarden “Organization” settings and also in the admin settings. In the admin setting when clicking “Resend invitation” I get this in the console
  • I tried inviting a new user on Vaultwarden on a different domain, same issue.
  • I installed Vaultwarden for the first time on a 3rd different domain, same issue.
  • I cross-checked SMTP settings between all 3 instances, they are all the same.
  • I changed ports and SMTP security values, I would get different errors for each. Below are examples of values and errors, used with Test SMTP field in Vaultwarden admin settings.
    1. These are default settings in all 3 instances on separate domains.

I have a hunch it’s a Vaultwarden issue specifically, the last user I invited was on 12 December 2023. This was 37 days ago, the last update I did on Vaultwarden was 25 days ago on 22 December 2023 and now it’s the first time I tried inviting users after the last update. So could it possibly look like an issue with the latest version?

Vaultwarden logs have stopped on October 2023. Have no idea why. So not providing those as they’re probably useless.

I very much appreciate help on this or stuff I can try, as it’s something we use on a daily basis.

Thank you!

1 Like

This is a long message, I know. Just trying to provide all the data I can.

First of all, thanks for that!

Some fixes about smtp have been made in the testing branch.
Coulf you please try again with after upgrading by
sudo yunohost app upgrade vaultwarden -u --debug ?


I just ran the upgrade but it finished because it said there is nothing to update.

root@yorkcollective:~# sudo yunohost app upgrade vaultwarden -u --debug 
263  DEBUG initializing base actions map parser for cli
265  DEBUG loading actions map
266  DEBUG building parser...
274  DEBUG building parser took 0.007s
276  DEBUG acquiring lock...
292  DEBUG lock has been acquired
342  DEBUG loading python module took 0.049s
343  DEBUG processing action [1453778.1]: with args={'app': ['vaultwarden'], 'url': '', 'file': None, 'force': False, 'no_safety_backup': False, 'continue_on_failure': False}
685  INFO Now upgrading vaultwarden...
868  DEBUG initializing ldap interface
1060 DEBUG Checking default branch
1736 DEBUG Downloading...
2460 DEBUG Done
2941 SUCCESS vaultwarden is already up-to-date
3329 DEBUG The permission database has been resynchronized
3635 DEBUG SSOwat configuration regenerated
3646 SUCCESS Upgrade complete
3647 DEBUG action [1453778.1] executed in 3.304s
3647 DEBUG lock has been released

Yesterday I ran the upgrade from this branch, and got an 502 error when going to Vaultwarden login page. I’m testing all this on a server where I don’t use Vaultwarden at all, so it’s a production server, but we don’t require yet Vaultwarden. I didn’t try on my production servers. But it should be exactly the same thing. Note that the branch above says 1.29.2 version in the URL but in the Readme file says 1.30.1~ynh1.

After running the upgrade I did Test SMTP and same error.

Yes sorry, could you try the same command, but with --force at the end?

And the 1.29.2 branch won’t work until we move to Bookworm so the 502 bad gateaway is “normal”.

It worked perfectly.

Am I OK to run the command on my other servers? Of course, I will make a backup first.

Just FIY

These are the new settings that have changed with the upgrade.

1 Like

Thanks for the update!
Don’t forget to mark the solution to make this thread as solved.

You can try or wait for the update. As long as you have a backup, all things should be solutionable ^^

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.