slapd/LDAP broken


I had a yunohost working quite smoothly for some months but obtain some error lately (not sure wether it was linked to the migration to debian 9).


First, I had issues with FreshRSS : new user could not modify anything. Reinstalling the app did the job but… I started to have issues with nextcloud. I believe some sync destroyed my mariadb and I had tons of error filling out my /var in seconds and crashing everything.
I sort of solved the problem by exporting/importing the db but I noticed I had a lot of

<= mdb_equality_candidates: (sudoUser) not indexed

errors in my /var/log/syslog
I found on the internet is was linked to slapd and thus

I did a

dpkg -- configure slapd

this broke everything

As I believe fixing is better than reinstalling, I’d like some help understanding how to solve my problems :

LDAP / slapd is broken and I could not login anymore with any user

I rebooted my server and logged in as root and made a new admin user hoping to solve everything… it did not of course. doing

yunohost list user  
Erreur : Une erreur est survenue lors de l'opération LDAP

tells me something is wrong with LDAP but I do not want to brake more stuff and am requesting you help :slight_smile:

How can I solv that ?

Oooookay well, imho doing dpkg -- configure slapd is a pretty bad idea :/… And trying to solve it by creating manually an admin user is likely to make it worse :sweat_smile:

I’m not sure in which state your LDAP db is now … maybe running yunohost-reset-ldap-password could be of some help, but I doubt it will magically resolve everything ?

Erf is the commands says an error happened during LDAP operation. am I doomed to reinstall ?

Hmmmm, do you happen to have a backup somewhere in the past ?

I think i setup core backups through the interface when i first install yunohost
thanks for the help BTW

Well it seems my /home/yunohost.backup/ folder is not so full so I guess I have to reinstall and be more cautious next time.
One question though, will I be able to use the same yunohost domain name ( ? This is rather important for me.

Yes you can ask us for the domain to be deleted, then you can reuse it :wink:

Sorry about the data loss / need to reinstall :s

Nothing in /home/yunohost.backup/archives/ ?

yunohost backup list
yunohost backup restore --system conf_ldap --ignore-apps -n NAMEOFYOURBACKUP

You can remove --ignore-apps if you are using YunoHost 3

just some apps, and nothing I really need :confused:

Oh well I just bought a OVH domain name for 1 buk, I will use it from now one so that I leave the domain names for newcomers :slight_smile:
Therefore you can delete/release the domain :

Thanks for the help and the great work on yunohot !

Done !

So I purchased a domain name at OVH and reinstalled le latest version of yunohost.
I currently have two problems :

  • there is no /var dedicated partition, is it safe to leave it as is ?
  • It says let’s encrypt cannot be used with my domain :open_mouth: how come ? | Solved, I guess all the dns entries did dot update at the same speed.
  • my local ip address does not seems to work | Oups that was because I needed to delete previous certificate

Hey I just noticed the brique camp was happening!

I am not sure how I can contribute but I would be interested in passing by, to see whether there is need for guys like me :slight_smile: is it open to everyone ?
If I can manage to take off work through the week, which day would be best ?
Hoping to meet you all
Cheers !

1 Like


Sure you are welcome :slight_smile:

I send you the address and phone number

You can come when you want (tomorrow could be good)

1 Like