Shiori results in a 502 Bad Gateway error after installation

My YunoHost server

Hardware: Raspberry Pi 4 8GB, YunoHost installed on microSD card
YunoHost version:
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello all,
I have just installed YunoHost and am experimenting with some apps. I’m also a newbie to anything domain, hosting and network related.

I want to install the Shiori app. So I created a subdomain (“”) and installed a Let’s Encrypt certificate for it (I had to manually add to /etc/hosts for the certificate to install).

But if I visit, I get a 502 Bad Gateway error.

The Shiori installation terminated error-free, but when starting the app I also get a 502 error.

In the webadmin Diagnosis, I’m not getting any red errors, except about my IP address being blacklisted by blocking sites. Under Services, I see that the Shiori service is not running.

Can someone help, please?

P.S.: There is no Shiori tag, and I cannot add one - but the system doesn’t let me post without a tag

What are Shiori service output log saying? Webadmin → Services → shiori
What about restarting the service?

I had to manually add to /etc/hosts for the certificate to install).

Why do you need to do this?

Here are the Shiori service output logs: hastebin

I didn’t want to try “restarting” the service because it never ran, even after a reboot, so I figured there must be something substantially wrong with the installation as such.

The extra line to /etc/hosts was necessary because the Let’s encrypt certificate for the new subdomain finished with an error (don’t have the log available any more, something it couldn’t write to). With this additional line, however, the certificate installed successfully, or so it says on webadmin Domains

Thanks, ericg

Ok, I just realize that you are installing on Raspberry… Shiori image has only been built for amd64 so it can’t work on ARM arch.

CF Release v1.5.0 · go-shiori/shiori · GitHub

Oh, bummer. I wish this was stated more explicitly somewhere, for those who are newbies and non-insiders (and, somehow, the target group of YunoHost).

I assumed that all the apps on the Applications page could also be installed. So that means whatever app doesn’t show an “ARM build” on their GitHub page cannot be installed on Raspberry. I’m surprised that in this case the app nevertheless flawlessly installed on Raspberry.

Can you tell me if that’s the same with the app Bibliogram? I had a similar problem when installing and couldn’t get it to run. On the GitHub pages of Bibliogram, I can’t find any info about available builds.

Thanks for your help!

Yes, I agree, but there is plans to make things more explicit about arch support in the future.

Meanwhile I have build a binary for ARM arch. You can test it here:

sudo yunohost app install

Edit. Note that the build is for ARM7.
(I can’t build for ARM64 due to cross-compiling. I don’t have arm64 platform :/)

Cool! Thanks, I’ll try the ARM build tomorrow.

Did you see my question about Bibliogram in my previous post?

Bibliogram should normally work on ARM. To be tested

Hi @ericg, I did manage to install Shiori with your ARM build on the command line. But then I could not log in. I expressly created a user “shioriuser” on, but no success, I always get “username doesn’t exist (500)”

Unless there is a simple solution for this, can you tell me how to uninstall Shiori on the command line?

To be clear, after installing Shiori, to log in to the app you used:

username: shiori
password: gopher

and you changed the default credentials in Shiori settings with your own username/password, you logged out and when you tried to log in again with the new credentials you got “username doesn’t exist (500)”… is that right?

No, I didn’t know about “shiori” and “gopher”

I started the app, got a login window, and tried the regular user I made for That got me a “username doesn’t exist (500)” error.

Then I thought maybe has its own user administration and I created a user “shioriuser” on But that didn’t work either, same error.

I just successfully logged in with username “shiori” and password “gopher” and I also found further instructions at

Thanks - all good, so far!

Also, the database is stored in /home/ This file stores the credentials and is not removed when your delete the app. So if you delete and reinstall the app, you will need to use your previous credentials.
If you want to remove the datadir alongside the app, use the --purge option:
sudo yunohost app remove shiori --purge

There is also a plugin available for Firefox

1 Like

Fantastic, thanks for all the info!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.