SFTP Music copy.... Help!

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 4.1.8
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen |
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

Hello everyone…

I give up… I’ve tried. Honest, I’ve tried everything before coming here.

I have a QNAP NAS with all of my music, all several gigs of it. For months I have been using yunohost with Nextcloud and Navidrome. I have been testing them together with a view to moving my whole library from the QNAP to my yunohost server which has NEVER given me ANY problems during these few months of use. (Thanks team for the great work)

I am using CyberDuck SFTP to transfer from the QNAP/share/music to the yunohost share/yunohost.multimedia/music folder.

I can connect using admin credentials to both servers. No problem

I can drag from the QNAP folder to yunohost, the files are counted ready to transfer and then STOP, I don’t have permissions on the yunohost shared folder even though I have logged in as admin.

I’ve searched for a solution and can’t find one, to write folders and files to the yunohost shared music folder.

I just need a quick and dirty way to copy from the QNAP to the YUNOHOST server all of my music. I can use the Nextcloud file app in a browser but that takes forever of course.

Any guidance/help would be very much appricated,

Many thanks and have a great weekend


I guess the most sensible way to solve this is to add “admins” group permission to the relevant folder:

setfacl -m g:admins:rwx /path/to/folder

@Aleks thanks… New to this. I guess the path/to/folder is the yunohost multimedia/music folder.?


It’s the folder you want to put music in from the admin user through SFTP

@Aleks thanks… I will try in the morning, see what happens

Thank you


Note: if your yunohost is in your private network (at home) you can connect on yunohost using root user instead of admin. It should solve your issue too.

@ljf ok thanks for that. I have my admin password etc, dumb question, how would I log in as ‘root’?

I see the first user created is root but if I use those credentials I can’t connect.

thank you

FOUND IT! Sorry. Its user: root, password: the admin password… Doh!!!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.