Setting up Mastodon Email with external SMTP

:us: English message (Message en français disponible)

My YunoHost server

Hardware: Personal computer
YunoHost version: 11.0.10.2
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I’ve installed YunoHost (ynh.domain.tld) for deploy my own Mastodon instance (social.domain.tld).
I’ve created an user for me, and Yunohost assign username@ynh.domain.tld as email address.
After first Mastodon install failed, i’ve run install again, and all it works great.

My problem is for email sending by Mastodon.
Mastodon use Yunhost SMTP built-in server by default, and if i’m trying to sign up in my Mastodon instance with an other email address with my domain like name@domain.tld , the Mastodon confirmation email is received in username@ynh.domain.tld inbox (read with Roundcube Yunohost app).

I would like to use my external email server, because i’ve a residential IP address blacklisted in DUHL.
My external email server work great with my wordpress website installed in Yunohost.
I would like to Mastodon use social@domain.tld email address for all of sent emails by Mastodon (this address is already created in my external email server).

For resume, Mastodon use Yunohost SMTP server with my own yunohost account email address (username@ynh.domain.tld).
I would like to use an extenal SMTP srver with a custom email address like social@domain.tld instead of the Yunohost SMTP Server with username@ynh.domain.tld

:fr: Message en français (English message available)

Mon serveur YunoHost

Matériel: Ordinateur personnel
Version de YunoHost: 11.0.10.2
J’ai accès à mon serveur : En SSH | Par la webadmin | En direct avec un clavier/écran
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

J’ai installé Yunohost (avec le domaine principal ynh.domain.tld) pour installer mon instance Mastodon (social.domain.tld).
J’ai créé un utilisateur pour moi-même, et Yunohost lui a attribué l’adresse mail utilisateur@ynh.domain.tld).
Après une première installation échouée de Mastodon, j’ai relancé l’installation et ça a fonctionné.

Mon problème concerne l’envoi de mails par Mastodon.
Mastodon utilise le serveur SMTP de Yunohost par défaut, et si j’essaie de m’inscrire sur mon instance Mastodon avec une audre adresse de mon nom de domaie prncipal, par exemple nom@domain.tld , l’email de confirmation Mastodon est reçu sur l’adresse mail de mon utilisateur Yunohost (utilisateur@ynh.domain.tld), consulté avec l’application Yunohost Roundcube .

Je voudrais utiliser mon serveur mail externe, car j’ai une adresse IP résidentielle listée DUHL.
Mon serveur mal externe fonctionne prfaitement avec mon site wordpress installé sur Yunohost, par exemple.
Je voudrais que Mastodon utilise une adresse mail comme scial@domain.tld pour tou les mails qu’il envoie (cette adresse existe sur mon serveur mail externe).

Pour résumer, Mastodon utilise le serveur SMTP de Yunohost, avec comme expéditeur l’adresse mail de mon compte Yunohost (username@ynh.domain.tld).
Je voudrais utiliser mon serveur SMTP externe avec une adresse spécifique comme social.domain.tld à la place du serveur SMTP de Yunohost qui utilise l’adresse mail de mon compte Yunohost.

If i try to sign up with a GMail address, the confirmation email is not received in my GMail InBox or in my Yunohost email InBox.

Have you tried changing the settings within Mastodon to use a 3rd-party SMTP relay?

Hello, i’ve note a settings for 3rd-party SMTP relay in Mastodon administration panel.