Service php7.3-fpm et php7.4-fpm ne redémarrent plus

,

Bonjour

Suite à la désinstallation de l’application “Radicale”, les services php7.3-fpm et php7.4-fpm sont inactifs, et ne redémarrent plus.

Je poste ici le log de la désinstallation qui a échoué :

https://paste.yunohost.org/raw/lipesuxabo

Si vous avez des suggestions, je suis preneur !

Je te redirige vers ce problème: Problème suite mise à jour vpnclient

Rebonjour à tous
Je viens de faire une mise à jour de la brique (il n’y avait qu’une seule mise à jour, qui a été rapide).
Suite à cette mise à jour, le service php7.3-fpm ne redémarre (de nouveau) plus.
J’ai essayé (de nouveau) la méthode proposée dans le lien, mais celle-ci n’a cette fois pas fonctionné.

Je copie ici le log d’erreur.

root@smidge:~# sudo systemctl restart php7.3-fpm
Job for php7.3-fpm.service failed because the control process exited with error code.
See "systemctl status php7.3-fpm.service" and "journalctl -xe" for details.
root@smidge:~# systemctl status php7.3-fpm.service
● php7.3-fpm.service - The PHP 7.3 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.3-fpm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2021-11-11 16:44:07 CET; 1min 4s ago
     Docs: man:php-fpm7.3(8)
  Process: 2103 ExecStart=/usr/sbin/php-fpm7.3 --nodaemonize --fpm-config /etc/php/7.3/fpm/php-fpm.conf (code=exited, status=78)
  Process: 2104 ExecStopPost=/usr/lib/php/php-fpm-socket-helper remove /run/php/php-fpm.sock /etc/php/7.3/fpm/pool.d/www.conf 73 (code=exited, status=0/SUCCESS)
 Main PID: 2103 (code=exited, status=78)

nov. 11 16:44:06 smidge.noho.st systemd[1]: Starting The PHP 7.3 FastCGI Process Manager...
nov. 11 16:44:07 smidge.noho.st php-fpm7.3[2103]: [11-Nov-2021 16:44:07] ERROR: [pool hotspot] the chdir path '/var/www/hotspot' does not exist or is not a directory
nov. 11 16:44:07 smidge.noho.st php-fpm7.3[2103]: [11-Nov-2021 16:44:07] ERROR: failed to post process the configuration
nov. 11 16:44:07 smidge.noho.st php-fpm7.3[2103]: [11-Nov-2021 16:44:07] ERROR: FPM initialization failed
nov. 11 16:44:07 smidge.noho.st systemd[1]: php7.3-fpm.service: Main process exited, code=exited, status=78/CONFIG
nov. 11 16:44:07 smidge.noho.st systemd[1]: php7.3-fpm.service: Failed with result 'exit-code'.
nov. 11 16:44:07 smidge.noho.st systemd[1]: Failed to start The PHP 7.3 FastCGI Process Manager.

Je suis preneur de toute suggestion !

Visiblement un problème avec l’app hotspot. Il y a eu le même soucis avec vpnclient, je fais une pr pour corriger ça.

oui, c’était effectivement ça, je viens de trouver la solution à l’instant même

rm -f /etc/php/*/fpm/pool.d/hotspot.conf

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.