Server unreachable on local network : episode 2


I’m opening a new topic but it is the same exact issue that i encountered in this one (living room laptop could access homeserver through wifi but not through ethernet, symptoms are exactly the same here) so feel free to merge them.

So i just bought a new pc, installed win11 and ubuntu22 in dual boot, wired it through ethernet and everything is great we’ll be happy forever. Except it cannot reach my homeserver. To be precise it can sort of reach it but it is extremely slow and everything is incomplete/unusable (css missing most of the time, apps don’t fully load or timeout, i can log into bitwarden through the browser extension but it cannot sync, etc.). As in the previous topic, i’ve checked ipconfig, fail2ban and everything i thought of but it seems all fine.

Some example screen caps (i can provide browser console outputs or anything else if it can help but i don’t want to overcrowd this first post) :

This took 40 seconds to load :

This took 10 seconds

Sometimes, CSS loads but it takes over 2 minutes :smiley:

Things get extra weird : the aforementioned living room laptop had the exact same issues until one day everything worked fine without any intervention or change (at least on my behalf). But now this new machine has the same issues and i’d prefer to understand what’s going on rather than wait for things to magically settle on their own…

Does anyone have any idea of infos or logs that i can provide to investigate ?

How do you try to access your server?

With its domain name : cannot reach user interface nor admin interface

With its public IP : cannot reach user interface nor admin interface

Wit its local IP : cannot reach user interface but admin interface fully works

Are your wifi and your ethernet on the same network/subnet? surprising everything works from the wifi but not from the wired connection.

Same cable ? Long ago, I had a “similar” problem, it took me very long to realize that the cable was the cause.

Yep everything is on the same local network, the only difference between wired and wifi is that wifi is coming straight out of the router and all wired connections are going through a switch. I already bypassing it with no success…

The laptop cable never changed and still magically worked after some time…

I have a strong feeling that the problem lies on the server side for two reasons :

  • every http request it gets is successful (status 200 in the browser console, so i’m guessing server is receiving requests and acknowledging) but then it hangs and either timeouts or delivers partial information.
  • i can log into services through external apps : my new element session is detected but it is syncing since yesterday with no success, i can log into bitwarden but not sync it and nextcloud web interface is unreachable but i’m pretty sure its webdav connection works but i’ll have to try later today…

I may be wrong and on a false track but either case i don’t know how to investigate…

I found a solution but i still do not fully understand everything : i simply added my server ip & url in the hosts file, all is well now…

Thanks to anyone who answered !

However if anyone has a bit of an explanation as to why it was almost partially working before that, i’m interested. In my understanding (that i know is basic and biased and approximative) computers and networks and stuff either works or fails but never in between…

Perhaps i forgot i did the same thing on the laptop at some point, sorry :grimacing:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.