Second time installing on RPi 2, second times that SSH stops working after a while

It’s the second time i install Yunohost on a Raspberry Pi 2.
First time i had to abandon it because for some reason, after a few days of use, and testing different apps, SSH used to times out all the time… i could only login like within 30 seconds after the Pi booted, then it was impossible to login via SSH afterwards. I thought i tested/installed some bad “unofficial” apps.

This time, i only installed WordPress and Roundcube. The install was properly updated/upgraded first. And like the previous time, the web server continues to work, but no luck for login with SSH. :confused:

ssh -l root 192.168.1.x
ssh: connect to host 192.168.1.x port 22: Operation timed out

Hi Zproc,

This could be many things. Maybe ssh itself or other system components like firewall or heavy load or …

I do not know nothing about raspberry but I guess you installed a debian on it (raspbian).

Could you take a look to your system logs (/var/log/) :

  • look at /var/log/auth, /var/log/syslog, /var/log/message searching for messages when you try to ssh
  • Take a look to your firewall rules (cmd : iptables -vnL)
  • Check you network configuration on your raspberry and on your desktop from where you try to connect (cmd : ip a)
  • Use the ssh “-v” options when you try to ssh

From the informations you will send us we will be able to begin to help you.


Sorry i hadn’t seen your reply. I didn’t install many things this time but after trying an unofficial app (Minchat), SSH stopped working again, i could not login even after a reboot. So as i had deleted some things i had and didn’t install much i just reflashed the SD Card.

And yes I use Raspbian, well i use the Pi IMG i downloaded from the site that must use Raspbian.

I’ll see how it’ll turn out this time. If i want to test another unofficial app i’ll test it first on Debian in a VM, seems safer. :slight_smile:

As i still have a problem with outgoing email not going through, i think i will just try to install and use OwnCloud which is what i need the most. Although for now, from the Pi and the Debian VM, both OwnCloud installs fail. Maybe it’s a temporary thing?.. i’ll try again later.