SearXNG update fails

Hardware: Old laptop or computer
YunoHost version: YunoHost 11.2.5 (stable).
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | … (all)
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:
If your request is related to an app, specify its name and version: SearXNG 2023.

Description of my issue

Updating SearXNG fails with " Error Nothing to save"

Log is at

it should be fix now with 2023.

sudo yunohost app upgrade searxng -u

should do the trick

From that I get:

Info: Now upgrading searxng…
Info: Creating a safety backup prior to the upgrade
Info: Collecting files to be backed up for searxng…
Info: Declaring files to be backed up…
Warning: Source path ‘/etc/systemd/system/uwsgi-app@searxng.service.d’ does not exist
Error: Could not back up searxng
Info: The operation ‘Create a backup archive’ could not be completed. Please share the full log of this operation using the command ‘yunohost log share 20231018-222413-backup_create’ to get help
Error: Nothing to save

Could you share the full log ?

Yeah, it’s at

I also have this problem. The update aborts because no backup of SeraxNG can be created. Because the file /etc/systemd/system/uwsgi-app@searxng.service.d does not exist, the backup process is terminated with an error message and of course no update is carried out.

The file really does not exist.

The uWSGI diest for searx does not seem to start correctly.

Log for this:

A restart of the service also fails.

sudo mkdir /etc/systemd/system/uwsgi-app@searxng.service.d

should solve it

Can you check your

Thank you very much, that solved the problem.
Backup and update go through cleanly after creating the directory.


This worked. Thanks!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.