Seafile fails to install :-(

Internet Cube with VPN (Lime2)
YunoHost version: (stable).
I have access to my server : Through SSH AND through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Installation of the SEAFILE package doesn’t work.

2022-03-30 08:31:57,976: WARNING - The main mountpoint of your system '/' is on an SD card, swap will not be added to prevent some damage of this one, but that can cause troubles for the app seafile. If you still want activate the swap, you can relaunch the command preceded by 'SD_CARD_CAN_SWAP=1

→ First installation with this subdomaine seafile/ (doesn’t work)
I tried a reinstallation with (doesn’t work)

→ log :

Thank you for your help !!

I manually reinstalled numby:

python3.7 -m pip install numpy

and I tried a fresh Seafile installation with testing version :

sudo yunohost app install --debug

But It doesn’t work. Perhaps do you understand this and could you help me :

2833345 ERROR Unable to install seafile: An error occurred inside the app installation script
2833370 INFO The operation 'Install the 'seafile' app' could not be completed. Please share the full log of this operation using the command 'yunohost log share 20220401-065157-app_install-seafile' to get help
2834813 WARNING Here's an extract of the logs before the crash. It might help debugging the error:
2834816 INFO DEBUG -       creating /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/ma
2834817 INFO DEBUG -       copying build/lib.linux-armv7l-3.7/numpy/ma/ -> /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/ma
2834819 INFO DEBUG -       copying build/lib.linux-armv7l-3.7/numpy/ma/ -> /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/ma
2834821 INFO DEBUG -       copying build/lib.linux-armv7l-3.7/numpy/ma/ -> /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/ma
2834823 INFO DEBUG -       copying build/lib.linux-armv7l-3.7/numpy/ma/ -> /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/ma
2834824 INFO DEBUG -       copying build/lib.linux-armv7l-3.7/numpy/ma/ -> /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/ma
2834826 INFO DEBUG -       copying build/lib.linux-armv7l-3.7/numpy/ma/ -> /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/ma
2834828 INFO DEBUG -       copying build/lib.linux-armv7l-3.7/numpy/ma/ -> /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/ma
2834829 INFO DEBUG -       copying build/lib.linux-armv7l-3.7/numpy/ma/ -> /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/ma
2834831 INFO DEBUG -       copying build/lib.linux-armv7l-3.7/numpy/ma/ -> /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/ma
2834833 INFO DEBUG -       creating /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/linalg
2834834 INFO DEBUG -       copying build/lib.linux-armv7l-3.7/numpy/linalg/ -> /tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/linalg
2834836 INFO DEBUG -       error: could not write to '/tmp/pip-build-env-e5exbkcw/lib/python3.7/site-packages/numpy/linalg/': No space left on device
2834838 INFO DEBUG -
2834840 INFO DEBUG -       ----------------------------------------
2834841 INFO DEBUG -   Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-v7xmxeav/numpy/';f=getattr(tokenize, 'open', open)(__file__);'\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-yebkd9p9/install-record.txt --single-version-externally-managed --prefix /tmp/pip-build-env-e5exbkcw --compile" failed with error code 1 in /tmp/pip-install-v7xmxeav/numpy/
2834843 INFO DEBUG -
2834845 INFO DEBUG -   ----------------------------------------
2834847 INFO WARNING - Command "/usr/bin/python3 -m pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-e5exbkcw --no-warn-script-location --no-binary :none: --only-binary :none: -i -- wheel setuptools<=59.4 packaging Cython>=0.29.24,<3.0 pythran "numpy==1.19.2; python_version=='3.7' and platform_machine=='aarch64'" "numpy==1.19.2; python_version=='3.8' and platform_machine=='aarch64'" "numpy==1.20.0; python_version=='3.8' and platform_machine=='arm64' and platform_system=='Darwin'" "numpy==1.20.0; python_version=='3.9' and platform_machine=='arm64' and platform_system=='Darwin'" "numpy==1.17.3; python_version=='3.7' and (platform_machine!='arm64' or platform_system!='Darwin') and platform_machine!='aarch64' and platform_python_implementation != 'PyPy'" "numpy==1.17.3; python_version=='3.8' and (platform_machine!='arm64' or platform_system!='Darwin') and platform_machine!='aarch64' and platform_python_implementation != 'PyPy'" "numpy==1.19.3; python_version=='3.9' and (platform_machine!='arm64' or platform_system!='Darwin') and platform_python_implementation != 'PyPy'" "numpy==1.21.4; python_version=='3.10' and platform_python_implementation != 'PyPy'" "numpy==1.20.0; python_version=='3.7' and platform_python_implementation=='PyPy'" "numpy; python_version>='3.11'" "numpy; python_version>='3.8' and platform_python_implementation=='PyPy'"" failed with error code 1 in None
2834848 INFO DEBUG - + ynh_exit_properly
2835316 WARNING Removing the app following the installation failure...

Thank you !
Merci !


Several issues here:

I guess you have followed that advice?

numpy/core/src/umath/loops.c.src:2919:1: fatal error: error writing to /tmp/ccsfgbPx.s: No space left on device

You SD card is getting full during the installation.

Please don’t do that. Let the app handle its dependencies itself.

Hi, Thank you Titupijean :

  1. About SD_CARD_CAN_SWAP=1, I didn’t understand what command it was ?
    The main install command ?

  2. It’s not possible that SD card is full (60 gigas and fresh and recent Yunohost installation)

  3. Ok, I uninstall this !

Can you help me about the two first points ?
Thank you.

Command line: SD_CARD_CAN_SWAP=1 yunohost app install seafile

What does say the diagnostics about it, or the command df -h ?

I would say leave it be, as long as it does not trigger any issues…

What does say the diagnostics about it, or the command df -h ?

Filesystem      Size  Used Avail Use% Mounted on
udev            447M     0  447M   0% /dev
tmpfs           100M  3.1M   97M   4% /run
/dev/mmcblk0p1   58G  2.2G   56G   4% /
tmpfs           500M     0  500M   0% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           500M     0  500M   0% /sys/fs/cgroup
tmpfs           500M   16K  500M   1% /tmp
/dev/zram0       49M  5.1M   40M  12% /var/log
tmpfs           100M     0  100M   0% /run/user/0
tmpfs           100M     0  100M   0% /run/user/1007

(I have renamed the thread, since we are writing in English)

56G should be enough indeed. I dunno what’s happening here. Can you try with the command I wrote above?

I’m trying now. A friend tells me to unhold this:

sudo apt-mark unhold armbian-firmware;
sudo apt-mark unhold linux-buster-root-current-lime2;
sudo apt-mark unhold linux-dtb-current-sunxi;
sudo apt-mark unhold linux-image-current-sunxi;
sudo apt-mark unhold linux-u-boot-lime2-current;

It was perhaps a bad idea (I don’t know if there are interactions between these upgrades and Seafiles installation)

It doesn’t work. :frowning:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.