Seafile: Error in installation script

Hello guys,

I want to install seafile and get an error. Hope, one of you can help.

My YunoHost server

Hardware: Raspberry Pi 4 at home
YunoHost version: 11.2.11.3
I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:
If your request is related to an app, specify its name and version: Seafile 9.0.9~ynh2

Description of my issue

I have start the install of the application “seafile”. I used the given parameters, choose my user (i only have one) as the admin and set a password. After a while there comes an error message (something went wrong with the installation script) and a log.

Here is the link to the log: https://paste.yunohost.org/raw/wapuzojuvi

Thanks very much in advance.

Hello,

Can you try the install of seafile 11 from the branch seafile_11 cf Seafile 11 by Josue-T · Pull Request #122 · YunoHost-Apps/seafile_ynh · GitHub

Hello,
i’ve tried it. It seams to be the same error (in my eyes ;-): installation script has an error)
Here the log-Link: https://paste.yunohost.org/raw/uwaqamiboh

Hello,

Can you try again. I found a small issue for armv8

Sorry, still errors

Seafile 11: https://paste.yunohost.org/raw/facogajiki

Seafile 9: https://paste.yunohost.org/raw/vexujatiwa

Hello,

bad news :scream:

For seafile 9 I won’t invest time to debug as it won’t be maintained.

For seafile 11 I think there are an issue in the way to use the docker binary. So I need to rework this part of the app to make it working also on armv8.