Roundcube Update failed from 1.5.0~ynh2 to 1.5.1~ynh1

Hello people,

I can’t update roundcube from 1.5.0~ynh2 to 1.5.1~ynh1

Here is my log:

Any help pointing me in the right direction on how to resolve this will be appreciated.

Thank you!

My YunoHost server

Hardware: VPS bought online
YunoHost version:
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

1 Like

The problem seems due to a SQL error with these lines when configuring the database

2021-12-19 12:43:41,084: DEBUG - Creating database schema... ERROR: [1050] Table 'collected_contacts' already exists (SQL Query: CREATE TABLE `collected_contacts` (
2021-12-19 12:43:41,085: DEBUG -  `contact_id` int(10) UNSIGNED NOT NULL AUTO_INCREMENT,
2021-12-19 12:43:41,085: DEBUG -  `changed` datetime NOT NULL DEFAULT '1000-01-01 00:00:00',
2021-12-19 12:43:41,085: DEBUG -  `del` tinyint(1) NOT NULL DEFAULT '0',
2021-12-19 12:43:41,085: DEBUG -  `name` varchar(128) NOT NULL DEFAULT '',
2021-12-19 12:43:41,085: DEBUG -  `email` text NOT NULL,
2021-12-19 12:43:41,085: DEBUG -  `firstname` varchar(128) NOT NULL DEFAULT '',
2021-12-19 12:43:41,085: DEBUG -  `surname` varchar(128) NOT NULL DEFAULT '',
2021-12-19 12:43:41,086: DEBUG -  `vcard` longtext NULL,
2021-12-19 12:43:41,086: DEBUG -  `words` text NULL,
2021-12-19 12:43:41,086: DEBUG -  `user_id` int(10) UNSIGNED NOT NULL,
2021-12-19 12:43:41,086: DEBUG -  PRIMARY KEY(`contact_id`),
2021-12-19 12:43:41,086: DEBUG -  CONSTRAINT `user_id_fk_collected_contacts` FOREIGN KEY (`user_id`)
2021-12-19 12:43:41,086: DEBUG -    REFERENCES `users`(`user_id`) ON DELETE CASCADE ON UPDATE CASCADE,
2021-12-19 12:43:41,086: DEBUG -  INDEX `user_collected_contacts_index` (`user_id`,`del`)
2021-12-19 12:43:41,086: DEBUG - ) /*!40000 ENGINE=INNODB */ /*!40101 CHARACTER SET utf8 COLLATE utf8_general_ci */)
2021-12-19 12:43:41,086: DEBUG - [FAILED]
2021-12-19 12:43:41,087: DEBUG - ERROR: [1050] Table 'collected_contacts' already exists

There is a topic here with the same problem Roundcube : issue with the last update - #12 by ppr

1 Like


The other topic that @rodinux mentioned is closed so I am posting here.

Is it recommended to wait for a new patch/version in the webadmin or should I do something else in the meantime?

(in my case, I am trying to update from 1.5.0~ynh1 to 1.5.1~ynh1 but the log files are similar)


Same problem here :
2021-12-29 12:42:12,797: DEBUG - Creating database schema… ERROR: [1050] Table ‘collected_contacts’ already exists (SQL Query: CREATE TABLE collected_contacts

Hi, same issue but different versions.

I post here to avoid spamming the forum, it seems the upgrade issue is widespread among the last versions.
(Sorry, I’ll quicky translate into english, I had written this in french before I saw this post :slight_smile: )

Mon serveur YunoHost

Hardware: : Online distant server (x86-64)
Yunohost version: 4.3.5
Access: SSH
Special things : yes
Explain GeoIP filter for nginx (see Tuto: Bloquer les requêtes selon le pays )


Upgrade from version 1.5.1~ynh3 to 1.5.2~ynh1 aborts, seems to be a table issue, according to log :

ERROR: [1050] Table 'collected_contacts' already exists

I tried the trick @ericg gave here, unsuccessfully.


I have also tried to run the new update which is available since a couple of days (from 1.5.0~ynh1 to 1.5.2~ynh1) and I still get an error:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.