Roundcube "Connection to IMAP server failed"

My YunoHost server

Hardware: Old laptop or computer (64-bit Acer Aspire 5741)
YunoHost version: 4.3.3 (stable)
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Background: I use Yunohost email only for “in house” messages (admin messages from the server, and messages sent to/from other server email addresses). This is because my ISP prevents the opening of port 25 on my router. Prior to its most recent update, Roundcube worked well for this purpose.

Problem: However, now with Roundcube version 1.5.0~ynh1 I can no longer access email; clicking the “Ro” icon in the user interface leads to a secondary Roundcube login page and, eventually, the message “Connection to IMAP server failed” appears in the bottom right corner of the screen.

I have tried the Rainloop app, and it successfully logs in to my email as always.

Question: Is there a way to configure Roundcube so that it will work on “in house” emails again? (This is not urgent, because I have Rainloop to fall back on, but I prefer Roundcube for its fuller set of features.)

Hi !
same issues here
Not fond why

EDIT : In browser console I can see a 401 unauthorized when trying to access POST
https://mail.server.tld/?_task=login

Hello,

Got same issue with a distant server after updating from 1.4.11 to 1.5.

Reverted to 1.4.11 to “fix” it.

I wondered if reverting to a previous version was the only way to fix it for now. I may do so if no other solution is forthcoming.

In 1.5 version, I have updated Roundcube config file to upstream. The only significant change I see is line 44 : $config['default_host'] = '%t'; instead of $config['default_host'] = 'localhost';

The config file is located here: /var/www/roundcube/config/config.inc.php

Maybe if you change it back to localhost instead of %t that will fixe the issue…

I also made a branch with the change. GitHub - YunoHost-Apps/roundcube_ynh at fix

1 Like

Thanks you for the reply
I just tested and it’s seems not working

sudo grep -R default_host  /var/www/roundcube/config/config.inc.php

/var/www/roundcube/config/config.inc.php:$config['default_host'] = 'localhost';

fyi File is RO

 sudo ls -al /var/www/roundcube/config/config.inc.php
-r-------- 1 roundcube roundcube 7337 nov.  26 12:44 /var/www/roundcube/config/config.inc.php

Maybe It’s hardcoded in db ?

Now when I try to connect I’ve got “Login failed”
Still have a 401 unauthorized

EDIT : I just refreshed browser and it’s ok … my bad

Making the change from ‘%t’ to ‘localhost’ solved it for me. Thanks ericg!

Hi,

Updated from 1.4.11~ynh2 to 1.51 : app seems to run correctly without any change in the config files :+1: