Roundcube 504 Gateway time-out

I have just installed roundcube but when I try to visit the app I’m greeted by a 504 Gateway Time-out error.

My YunoHost server

Hardware: Raspberry Pi 4 at home
YunoHost version:
I have access to my server: Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance? Yes, I modified dphys-swapfile to use up to 8GB of swap.

Description of my issue

I have installed Roundcube on a subdomain using the webadmin:

  • url: /
  • cardDAV plugin: yes
  • language: en_GB
  • Here is the log.

But when I tried to access the webmail, I couldn’t. I see the 504 Gateway Time-out error both from within the network and outside.

I have tried changing the Expected usage of the service setting from low to medium in case that was the issue, but it didn’t work.

It seems to be the same issue as described here. if that’s the problem, I could edit the file, but I’d need clear instructions.

I would also like to know what to do to/how can I encrypt (GPG, MIME?) my email (fully hosted on YunoHost). Do I need an email client for that on the server? Or can the server create a key that could be exported and imported into other [mobile/desktop] devices? Should I create a new topic for that? I think so.


Any help would be appreciated :slightly_smiling_face:

Ugh yeah i’m not sure what’s the exact issue / fix either … the topic seems to point to something which is not applicable anymore because the “default_host” key doesnt exist anymore, Instead there are these : roundcube_ynh/ at master · YunoHost-Apps/roundcube_ynh · GitHub

So I don’t know exactly what to do with these or if the issue really is related to this é_è

Super wild guess : maybe running

postmap -F hash:/etc/postfix/sni

could fix the issue, cf other discussions related to (desktop) mail clients displaying a self-signed cert instead of lets-encrypt cert … but not really convinced that’s the underlying issue

It didn’t work, still seeing the 504 error when I try to visit the url. Thanks anyway.
I’ll configure my desktop and mobile clients instead.

I just pushed a fix to the master branch. Can you try again to install (no sure it will fix your issue thought).

I had already tried installing the update when I wrote my previous reply.

Just to be safe I uninstalled and installed roundcube again on the same domain (Let’s Encrypt) and also on a different one (self-signed certificate).

The second domain is also unavailable with a difference: first one shows Nginx’s 504 error and second one simply doesn’t load anything.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.