Revert smtp relay in 4.1

My YunoHost server

Hardware: computer
YunoHost version:
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen |
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

tested the smtp relay according to your write up - YunoHost • index

That worked perfect, but now I’m a bit unsure on how to revert back? …I didn’t made any notes and some time past :blush:

Should it be; 
  default: False


set False

or something els

Maybe someone could check the default setup and paste info for the

sudo yunohost settings list

Any help appreciated.

i believe if you just set the host to empty string ('' or "") that should do the trick…

Or there might be an option in yunohost settings set --help to revert to default ?

1 Like

Thanks Aleks,

yeah, it sort of working

This does not work (with or without space ‘’ ’ ');

$ sudo yunohost settings set -v ''
Error: Argument 'value' is required

This works with warnings;

$ sudo yunohost settings set -v ´´
/usr/lib/moulinette/yunohost/ UnicodeWarning: Unicode unequal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
 if old_value != new_value:
Warning: 'yunohost service regen-conf' is deprecated! Please use 'yunohost tools regen-conf' instead.
Warning: Traceback (most recent call last):
Warning:   File "/usr/bin/yunohost", line 72, in <module>
Warning:     parser=parser
Warning:   File "/usr/lib/moulinette/yunohost/", line 29, in cli
Warning:     top_parser=parser
Warning:   File "/usr/lib/python2.7/dist-packages/moulinette/", line 120, in cli
Warning:     args, output_as=output_as, timeout=timeout
Warning:   File "/usr/lib/python2.7/dist-packages/moulinette/interfaces/", line 496, in run
Warning:     print(ret)
Warning: UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-1: ordinal not in range(128)
Warning: The configuration file '/etc/postfix/sasl_passwd.db' has been manually modified and will not be updated
Warning: The configuration file '/etc/postfix/sasl_passwd' has been manually modified and will not be updated

Does it make sense?

Mmh I think the best way is to use the appropriate reset setting. Try
sudo yunohost settings reset [the setting you want to reset]
sudo yunohost settings reset-all (for all settings).

All the appropriate settings commands are shown when you sudo yunohost settings -h


Thanks Tho, that did the trick :pray:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.