Restored backup on new 64bit install, admin user disappeared

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version:
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Trying to upgrade from 32 bit to 64 bit. Reinstalled yunohost on my sd card with most recent image, restored backup instead of post-install… Can’t access admin anymore, old password doesn’t work.

Found some similar topics on the forum but no solutions (or not confirmed/weird to apply them/thought it would be useful to report the problem). Suspect this is related to 11.1/11.0 trouble (previous installation was on 11.1 or superior as far as I can remember).

Trying to change admin password returns unable to change admin password : error during LDAP search operation with: base='cn=admin,dc=yunohost,dc=org', filter='(objectClass=*)', attrs=None and exception {'desc': 'No such object', 'matched': 'dc=yunohost,dc=org'}

What to do? Always tried to have everything up to date, previous installation worked smooth

I restored few weeks ago on my Raspberry PI 4 a 32 bits backup (ver 11.2…) on a Raspi OS 64 bits, but I didn’t follow the same procedure. Here is this other procedure:

  • Install Yunohost 11.0 image
  • Perform post installation with the admin/root password of the 32 bits backup
  • Perform system upgrade
  • Restoration. There was some problems on Synapse and Nextcloud but I fixed them.
    I hope this can help you.
1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.