Restic and users permissions


My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version:
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain: —

Description of my issue


I have recently installed restic to manage my backups. After installing, I got this message after every sudo command: sudo: /etc/sudoers is world writable

So I checked the forum and then the web and found this topic with this fix:

pkexec chmod 555 /etc/sudoers
pkexec chmod 555 /etc/sudoers.d/README

I did that and solved my sudo issue. But, after that, impossible to install new apps, because of permissions issues. Here a log of a failed installation and here another one.

And even the Restic backups are failing. Restic backup failed log

How can I fix these permissions issues?

Thank you,
Best regards.


Description du problème


J’ai récemment installé Restic pour la gestion de mes backups. Après installation, j’avais ce message d’erreur après chaque commande sudo :

sudo: /etc/sudoers is world writable

Alors j’ai cherché sur le forum, puis le web et trouvé ce topic avec cette solution:

pkexec chmod 555 /etc/sudoers
pkexec chmod 555 /etc/sudoers.d/README

Ce que j’ai fait, et cela a corrigé mon problème. Mais après cela, impossible d’installer de nouvelles applications, à cause de problèmes de permissions. Un log d’une installation ratée et un autre exemple.

Et même les sauvegardes restic ne fonctionnent pas. Log d’un backup restic raté

Comment puis-je corriger ce problème?

Merci d’avance et meilleures salutations.

Where do you see these permission issues? These failures seem unrelated (build error and dependencies issue, respectively).

WARNING - subprocess ssh: Bad owner or permissions on /root/.ssh/config

What’s the output of ls -la /root/.ssh/config ? My guess is it is readable/writable not only by root user.

If so:

chown root:root /root/.ssh/config
chmod 660 /root/.ssh/config

this is just a personal extrapolation


-rw-rw-rw- 1 root root 217 Mar 5 22:04 /root/.ssh/config

I dit it and now I have:

-rw-rw---- 1 root root 217 Mar  5 22:04 /root/.ssh/config

I tried the installation of lemmy and it failed again : log

So I tried something that I knew it should work because already installed in the past : Bludit and it worked log. Perhaps because of dependencies or sowhat.

Then I tried again PixelFed and it failed. log 1 - log 2 - log 3 - log 4

So I have another problem on my server but I don’t know what and this was since the installation of restic…

I am guessing that it could be due to one of Lemmy’s dependency, Hyper, not being buildable on your system architecture, armhf.

For both Lemy and Pixelfed, I suggest you open dedicated threads for them. Their issues seem unrelated to Restic.

1 Like

Thank you for your help!

You’re probably right. And this case, I give up the installation of lemmy and Pixelfed.

About Restic, I get every day a mail that says the backup was successfull but I don’t see any file in the corresponding backup folder on my NAS.

For the moment, I give up that too. I will come back to it later maybe.

So the topic is done fo me. Thank you again Titus for your help. :wink:

Best regards.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.