[Résolu] SSH refusé port 22

Bonjour,

Je commence tout juste avec yunohost et donc avec l’environnement serveur.

J’ai réussi a installé et avoir accès à la partie admin.

J’ai réussi a installé nexcloud qui fonctionne.

Mais impossible d’accéder en ssh au serveur. Il refuse …

Que ça soit en root, admin ou login.

J’essaie aussi d’installer Shell In A Box, mais rien ne se passe … Pacman risque l’obésité …

Merci de votre aide.

Bonjour et bienvenue par ici,

Sur quel ordinateur ou machine est installé Yunohost ? C’est pour savoir si un accès avec un écran et clavier est possible si le SSH ne fonctionne pas.

est-ce que la consultation de cette page peut débloquer la situation https://yunohost.org/#/ssh ?
Lors de la commande ssh, quel est le message de retour affiché?

C’est l’installation de l’application qui ne fonctionne pas ou la connexion via l’application comme au point précédent ?

Merci,

Il est vrai que je n’ai pas ete tres explicite.

Mon installation est sur un Rpi3b+.

Le message est : Permission denied, please try again. ou ssh: connect to host nomdedomaine.ext port 22: Connection refused
Le lien est celui que j’ai suivi au début pour essayé de me connecter.

Enfin l’apps ne veut tout simplement pas installer.

merci.

Bonjour,

J’ai eut ce problème avec le même matériel. J’avais réussi à le résoudre en remettant les locals avec un raspi-config ?

G

Bonjour,

Les locals ??? genre fr_FR-UTF8 ? Je sais pas si j’ai bien compris mais si oui, je vois pas le raport!
Mais peut être veut tu parler d’activer le serveur ssh dans “Interfacing Options”

@hercut, regarde le message de Guillermo et ma réponse ci-dessus.

Questions subsidiaries :

  • Tu as installer yunohost à partir de l’ISO ou du script d’installation ?

Pacman ? :hushed: apt / apt-get /aptitude, non ? :face_with_raised_eyebrow:

Comme le dit @Guillermo, le port 22 du RPI n’est en effet pas ouvert directement, mais nécessite parfois un petit changement.

Si tu fais, ‘sudo raspi-config’ (navigue avec avec les flèches + touche “entrée”), tu vas pouvoir voir une option en Interfacing Options. Tu vas dans SSH ensuite tu choisis YES puis OK. Et “Finish” quand c’est bon. Normalement ça devrait ouvrir le port 22 (j’utilise les indications en anglais, mais cela peut changer en fonction de langue utilisé.)

Bonsoir @hercut,

En complément de @frju365 , tu peux jeter un œil ici :
https://avignu.wiki.tuxfamily.org/doku.php?id=documentation:yunohost-stretch-v3.x.x.x-rpi#activer_ssh_et_autoriser_les_connexion_de_root_en_ssh
Pas obligé d’être root, mais bien activer SSH.

ppr

1 Like

Bonjour,

Merci à tous de votre aide et réactivité ! Ça fait plaisir.

J’ai pris le parti de refaire l’installation, je voulais essayer de comprendre pourquoi ça faisait ça au début.

Mais de refaire l’installe m’a orienté vers un élément de réponse.

Lors de la config du mot de passe du root lors du premier accès à celui-ci, il demande un mdp.

Je pense que je n’avais pas fait correctement.

Ce qui avait dû bloquer les accès.

Maintenant ça fonctionne, merci de votre aide et je vous présente mes excuses pour la gêne, je pense que le post peut être surprime.