[Résolu/Solved] Impossible de passer des commandes en SSH

Bonjour à tous.

J’ai un serveur YNH installé sur un VPS.
Je souhaite acceder en ssh au serveur pour mettre à jour les droits des utilisateurs suite à la nouvelle version.

Cependant, quoi que je veuille faire, la commande sudo yunohost * me renvoie un message d’erreur.

Exemple avec ‘sudo yunohost --help’

:~$ sudo yunohost --help
Traceback (most recent call last):
  File "/usr/bin/yunohost", line 77, in <module>
  File "/usr/lib/python3/dist-packages/yunohost/__init__.py", line
41, in cli
    ret = moulinette.cli(
  File "/usr/lib/python3/dist-packages/moulinette/__init__.py", lin
e 111, in cli
  File "/usr/lib/python3/dist-packages/moulinette/interfaces/cli.py
", line 477, in __init__
    self.actionsmap = ActionsMap(
  File "/usr/lib/python3/dist-packages/moulinette/actionsmap.py", l
ine 463, in __init__
    self.parser = self._construct_parser(actionsmap, top_parser)
  File "/usr/lib/python3/dist-packages/moulinette/actionsmap.py", l
ine 630, in _construct_parser
KeyError: 'arguments'

Par ailleurs, je n’arrive pas à me connecter à l’interface d’admin via mon navigateur.
Ni avec mon user/mdp, ni avec admin/mdp.

Sauriez-vous m’aider ?

Bien respectueusement.

Hello all, I have the same issue and same deployment setting (yunohost on debian VPS). I’m unable to login via webadmin and have the same issues from cli that user ourssansplus posted above. Services and apps seems to work fine.

Thank you in advance to everyone!

1 Like

What’s your active yunohost versions ?

dpkg -l | grep yunohost

And after, if you can’t run yunohost tools upgrade system, try to upgrade manually:

apt update
apt full-upgrade

If you can give us the return of these commands it’s better

COuld you say if you have unattended-upgrade installed ?

yunohost version 11.1.5
yunohost-admin 11.1.4

unattended-upgrade est installé, en effet.
full-upgrade est en cours

unattended-upgrade is installed, indeed.
full-upgrade is in progress

Hi @ljf I can confirm that following your suggestions has worked for me. It listed moulinette, ssowat, yunohost and yunohost-admin as upgraded and now I’m able to both login to webadmin and execute commands via cli.

Thank you!

Idem pour moi ici !

J’ai desinstallé ‘unattended-upgrade’, d’après tes précédents messages @ljf c’est lui le coupable.

My server is up and running again. Merci beaucoup :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.