[Résolu] Problème après la mise à jour de SearXNG - Problem after updating SearXNG


Je viens de faire la mise à jour vers SearXNG, et problème avec cette
mise à jour.

J’ai dû désinstaller SearXNG et faire une restauration avec la sauvegarde et ça fonctionne.
Je ne suis pas le seul, un ami m’appelé, il y a 20 min environ, pour me signaler le même problème. Je lui ai conseillé de supprimer la mise à jour et d’utiliser la sauvegarde et là, ça fonctionne.

Si quelqu’un à une solution, je suis preneur, merci :pray:

Bonne journée à tous.


Good morning,

I just updated to SearXNG, and problem with this

I had to uninstall SearXNG and restore with the backup and it works.
I’m not the only one, a friend called me about 20 minutes ago to report the same problem. I advised him to delete the update and use the backup and there it works.

If anyone has a solution, I’m interested, thanks :pray:

Good day to all.

Indeed, same here!

1 Like

Moi aussi…
Que faire?

first things to do is filling the template & sharing log…

My YunoHost server

Hardware: VPS bought online
YunoHost version: (stable)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

After updating from version 2024. to version 2024., SearXNG no longer works. When calling the app, an error page (ngix) 504 Gateway Timeout appears after some time.


2024/05/13 19:13:53 [error] 857330#857330: *1436910 upstream timed out (110: Connection timed out) while reading response header from upstream, client:, server: searx.pericles.hu, request: "GET / HTTP/2.0", upstream: "uwsgi://unix:///var/run/searxng/app.socket", host: "searx.pericles.hu"

1 Like

ok and what say yunohost/admin/#/services/uwsgi-app@searxng especially /var/log/uwsgi/searxng/searxng.log ?

The issue seems to be in you configuration, you try to load 2 engines that doesn’t exist:

  • duckduckgo_images
  • google_play_apps
    have you tried to remove them ?

Removing it does not change anything.

For me it’s after last SearXNG’s update the problem appear

A new update is available, let us know if it solves or not … :crossed_fingers:

1 Like

Update done, but still the same problem :weary:

Same for me : still not working

Bonjour à tous,

Il semble que la mise à jour provoque une erreur 504 Gateway Timeout, empêchant SearXNG de fonctionner correctement… bon courage à tous

Not everybody face that problem, me for example…
Did someone try with a proper install ?
What says the uwsgi log ?

What, delete the app and do a fresh install?

The error remains even after the update.

I will try to completely uninstall SearXNG tomorrow and reinstall it.

yes without any customization

J’ai résolu chez-moi le problème, il semble y avoir un souci avec ce raccourci :
ERROR:searx.engines: Engine config error: ambiguous shortcut: c3tv

Info qui m’a permis de résoudre mon souci :
without further subgrouping
Puis :

Donc, j’ai remplacé dans cette ligne qui se trouve :
/var/www/searxng/settings.yml, (Je précise ici, que ce sont mes paramètres personnalisés que vous pouvez retrouver dans yunohost/admin/#/apps/searxng/operations :wink:

  - name: ccc-tv

Par :

  - name: media.ccc.de

On fait un Ctrl+o pour enregistrer et Ctrl+x pour fermer et on lance la commande : systemctl restart uwsgi-app@searxng.service
Chez-moi, ç’a résolu mon problème.

Deleting and reinstalling also solved the problem.

1 Like