[Résolu] Erreur, je n'ai pas de réponse API

Bonjour à tous, toutes,

Bien que ce soit un sujet fréquent, j’ai déjà lu pas mal de posts équivalents mais aucun n’a résolu mon problème de "pas de réponse de l’API"

Le contexte :

  • une Raspberry Pi 2 derrière ma box maison
  • fais un upgrade systeme à la main “apt upgrade” et redémarré
  • j’accéde à la pi via ssh
  • j’ai essayé avec Opéra, FF, Chrome
  • j’ai tenté un service yunohost-api restart
  • un systemctl status yunohost-api -l :
systemctl status yunohost-api -l
● yunohost-api.service - YunoHost API Server
   Loaded: loaded (/lib/systemd/system/yunohost-api.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2020-11-15 15:32:58 GMT; 8min ago
 Main PID: 1700 (yunohost-api)
    Tasks: 2 (limit: 881)
   CGroup: /system.slice/yunohost-api.service
           └─1700 /usr/bin/python2 /usr/bin/yunohost-api

Nov 15 15:32:58 yunohost systemd[1]: Started YunoHost API Server.
  • tail -n 150 /var/log/daemon.log:
Nov 15 15:09:08 yunohost systemd[1]: Starting Clean php session files...
Nov 15 15:09:09 yunohost systemd[1]: phpsessionclean.service: Succeeded.
Nov 15 15:09:09 yunohost systemd[1]: Started Clean php session files.
Nov 15 15:27:19 yunohost systemd[1]: yunohost-api.service: Main process exited, code=killed, status=4/ILL
Nov 15 15:27:19 yunohost systemd[1]: yunohost-api.service: Failed with result 'signal'.
Nov 15 15:27:20 yunohost systemd[1]: yunohost-api.service: Service RestartSec=1s expired, scheduling restart.
Nov 15 15:27:20 yunohost systemd[1]: yunohost-api.service: Scheduled restart job, restart counter is at 4.
Nov 15 15:27:20 yunohost systemd[1]: Stopped YunoHost API Server.
Nov 15 15:27:20 yunohost systemd[1]: Started YunoHost API Server.
Nov 15 15:32:44 yunohost systemd[1]: Stopping YunoHost API Server...
Nov 15 15:32:44 yunohost systemd[1]: yunohost-api.service: Main process exited, code=killed, status=15/TERM
Nov 15 15:32:44 yunohost systemd[1]: yunohost-api.service: Succeeded.
Nov 15 15:32:44 yunohost systemd[1]: Stopped YunoHost API Server.
Nov 15 15:32:44 yunohost systemd[1]: Started YunoHost API Server.
Nov 15 15:32:57 yunohost systemd[1]: yunohost-api.service: Main process exited, code=killed, status=4/ILL
Nov 15 15:32:57 yunohost systemd[1]: yunohost-api.service: Failed with result 'signal'.
Nov 15 15:32:58 yunohost systemd[1]: yunohost-api.service: Service RestartSec=1s expired, scheduling restart.
Nov 15 15:32:58 yunohost systemd[1]: yunohost-api.service: Scheduled restart job, restart counter is at 1.
Nov 15 15:32:58 yunohost systemd[1]: Stopped YunoHost API Server.
Nov 15 15:32:58 yunohost systemd[1]: Started YunoHost API Server.
Nov 15 15:39:08 yunohost systemd[1]: Starting Clean php session files...
Nov 15 15:39:10 yunohost systemd[1]: phpsessionclean.service: Succeeded.
Nov 15 15:39:10 yunohost systemd[1]: Started Clean php session files.

hmmm bon je laisse mon post pour d’autres personnes mais il semble que ce soit dù au modèle de ma PI : c’est une PI 2 Model A et elle semble limitée en mémoire.
J’ai l’impression que c’est dù à ça.
Je vais essayer un modèle 3

(Pour compléter : on en a discuté sur le chat et il semblerait aussi que ce soit lié au fait que le Pi2 Model A soit encore une architecture ARMv6 et non ARMv7 (comme c’est le cas par exemple pour le Pi2 Model B))

Attention, le Pi2B existe en deux versions : la première avec un SoC ARMv7, la seconde (dite 1.2) avec un SoC ARMv8 (le même que le Pi3B mais sous-cadencé).

Enfin il n’y a pas à ma connaissance de Pi2A, j’imagine que tu parles du PiA+ ?

Effectivement c’est un Arm6 que j’ai.
Malheureusement je n’ai pas du tout réussi à démarrer mes autres cartes: PI2 Modèle B et une PI3 non plus.
Etant headless je ne sais pas où ça coince et comme le réseau n’est pas monté, impossible de faire un ssh dessus.

Je clos ce sujet car j’ai trouvé il s’agit d’un problème de SD Card, pourtant une Samsung bien propre sur elle qui à pourtant déjà accueilli Rapsbian, mais semble poser problème avec cette image.