[Résolu] Aide pour DNS chez mon registrar

Mon serveur YunoHost

Matériel: Raspberry Pi à la maison
Version de YunoHost: 3.5.2.2
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifiiations particulières sur votre instance ? : non

Description du problème

Bonjour,

j’ai un nom de domaine chez un registrar.

Je suis d’abord allé voir dans la web administration de Yunohost, voir la configuration DNS à mettre chez mon registrar qui administre mon domaine :

; Basic ipv4/ipv6 records
@ 3600 IN A 90.43.23.251

  • 3600 IN A 90.43.23.251

; XMPP
_xmpp-client._tcp 3600 IN SRV 0 5 5222 arnauld.org.
_xmpp-server._tcp 3600 IN SRV 0 5 5269 arnauld.org.
muc 3600 IN CNAME @
pubsub 3600 IN CNAME @
vjud 3600 IN CNAME @

; Mail
@ 3600 IN MX 10 arnauld.org.
@ 3600 IN TXT “v=spf1 a mx ip4:90.43.23.251 -all”
mail._domainkey 3600 IN TXT “v=DKIM1; h=sha256; k=rsa; p=MIGfMA0GCSq…”
_dmarc 3600 IN TXT “v=DMARC1; p=none”

; Extra
@ 3600 IN CAA 128 issue “letsencrypt.org

Chez mon registrar, je pense être au bon endroit pour mettre ces informations :

J’ai bien mis l’adresse IP de mon Yunohost, 90.43.23.251, dans les lignes :
A @
A mail
cname www

Mais est-ce suffisant ? Comment rentrer et dois-je rentrer d’autres informations ?

Merci.

As-tu regardé par ici ?
https://yunohost.org/#/dns_config_fr

1 Like

Bonjour,
Alors avant toute chose, je vois faire un backup, donc je pense qu’il est utile d’en faire un.

Ensuite, si souhaites gérer mail et site sur ton Yunohost et uniquement depuis celui-ci, je te conseille d’enlever tous les records installés par le registrar (sauf NS ou SOA): record de type CNAME, le record avec le nom “mail” (type A). Il faut comparer avec les conf DNS de ton domaine sur Yunohost (sans tenir compte des records NS) et supprimer/rajouter les record en trop ou manquant.

Tu peux aussi peut-être le faire plus simplement : Y a-t-il un mode textuel (ou expert) dans l’interface de ton registrar ?

1 Like

Merci! Non effectivement je n’avais pas vu cette page explicative. J’ai donc enlevé le superflu chez mon registrar et ajouté le nécessaire, ce qui me donne ça :

Maintenant j’attends pour voir si ça marche…

Et pour Let’s encrypt ?

; Extra
@ 3600 IN CAA 128 issue “letsencrypt.org

Comment rajouter chez mon registrar ? Dans le menu déroulant d’ajout je n’ai que :

A
AAAA
CNAME
MX
SPF
TXT
NS
SRV

Merci.

Alors : il faut déjà supprimer ce record : A mail …

En fait, le record A permet de lister les sous-domaines d’un domaines. Si tu mets un “A mail tonip…” (qui équivaut à “mail 3600 IN A tonip”) voudra dire que tu crées un sous-domaine : mail.arnauld.org.

Cependant, ce record (ajouté par ton registrar à l’origine est inutile) car tu as un record : “A * tonip” (que tu as ajouté par la ligne : * 3600 IN A tonip) qui signifie que tous les sous-domaines vont être relié à ton adresse IP. Le le record du sous-domaine “mail” vu précédemment peut donc être supprimé car il est déjà inclus dans le “*”.

(Petite précision : le “@” signifie que le registrar - tous - font une différence entre le sous-domaine et le domaine lui-même. Le @ correspond donc au domaine lui-même).

1 Like

Pour le record CAA, en effet, il n’est pas toujours présent, car il n’est pas “essentiel” (permet juste de renforcer la sécurité). Peux-tu regarder s’il est possible de modifier les records (on appelle cela la “zone”) en mode textuel ?

Petite explication : Quand tu met un record CAA avec le mot letsencrypt.org, tu dis en fait que ton domaine ne pourra accepter QUE des certificats délivré par l’autorité de certification Let’s Encrypt. Le navigateur vérifiant les records pourra refuser de se connecter au domaine en https si celui-ci par exemple utilise une autre autorité de certification.

J’ai une option “Importer une zone texte” :

Mais si je rentre @ 3600 IN CAA 128 issue "letsencrypt.org" tel quel, j’obtiens un message d’erreur :

Attention le fichier que vous souhaitez mettre, n’est pas valide.
Votre demande n’a pas été prise en compte.

Je me demandais également si je devais rentrer cette information avec les guillemets :

TXT @ “v=spf1 a mx ip4:90.43.23.251 -all”

ou sans les guillemets :

TXT @ v=spf1 a mx ip4:90.43.23.251 -all

peut tu copier tous ce que tu as dans la conf Yunohost ? Il possible qu’il te mette ça car c’est incomplet (il veut sûrement remplacer la zone existante par ce que tu as écrit).

Avec les guillemets normalement. Après, ça dépend s’il le met automatiquement ou pas (en mode graphique). Si tu le mets en mode textuel, toujours des guillemets.

Non, je ne peux pas. Si je copie tout ce que j’ai dans la conf Yunohost j’ai le même message d’erreur :

Attention le fichier que vous souhaitez mettre, n’est pas valide.
Votre demande n’a pas été prise en compte.

Ok. Ben, laisse tomber. Dans la mesure où le record CAA n’est pas essentiel (on va dire qu’il y a des moyens de proposer une grande sécurité sans ce record DNS), autant ne pas se casser la tête avec ça (à moins que qqn ait une idée bien-sûr).

Ok, merci pour tes réponses en tout cas.

De toute façon, malgré tous ces réglages mon serveur arnauld.org n’est toujours pas accessible… La propagation DNS est pourtant effectuée.

mh… de chez moi, ça fonctionne. Est-tu sur un box soumis au Hairpining ?

Ah bon ? Tu as accès à arnauld.org ? C’est déjà une bonne nouvelle alors.

Car en effet, j’ai une box Orange qui a du Hairpining. Il y a plus d’un an, quand j’avais un serveur Yunohost avec un domaine en ynh.fr fourni pas Yunohost, j’avais été confronté à ce problème…Pourtant je l’avais résolu depuis et je n’ai pas touché aux réglages de la box depuis que j’ai ré-installé Yunohost avec ce nouveau nom de domaine arnauld.org

Alors, je ne sais pas, mais j’y ai bien accès. Moi,au moment où j’étais chez Orange, j’utilisais l’extension anonymox de firefox qui permet d’obtenir un VPN. Pas sûr que ce soit super niveau confidentialité des données (ce que devrait faire le VPN), mais ça fonctionne pour éviter le hairpining.

1 Like

Bon, j’y suis arrivé en modifiant le fichier host de ma machine (d’où j’essaye d’accéder à mon serveur) tel qu’indiqué :

Configure hosts file on client workstation

Modifying hosts file should be done only if you cannot alter your box’s DNS or router, because hosts file will only impact the workstation where the file was modified.

Windows hosts file is located at: %SystemRoot%\system32\drivers\etc\

    You MUST activate hidden and system file display to see the hosts file.

UNIX systems (GNU/Linux, Mac OS) hosts file is located at: /etc/hosts

    You MUST have root privileges to modify the file.

Add a line at the end of the file containing your server private IP followed by a space and your domain name

192.168.1.62 domain.tld

source : https://yunohost.org/#/dns_local_network

1 Like

yes. C’est super. L’idée de l’extension, c’est juste une solution d’urgence.

Merci du coup de main, en particulier pour les DNS.