Requirements are not met, the package yunohost (2.6.5) must be >= 2.7.2


Hello everyone,

I am trying to install new application in Yunohost within my internet cube (la brique internet en français), but when I try to install “Roundcube” or “Searx” I get the following error:

Requirements are not met, the package yunohost (2.6.5) must be >= 2.7.2

In consequence I went to the following tab ‘System update’ but I am having the following message:

ssowat will be upgraded automatically within the next hour.
moulinette will be upgraded automatically within the next hour.
yunohost-admin will be upgraded automatically within the next hour

But after waiting 2 hours, nothing is happening: there is no update of my yunohost-admin.

Can you help me with this situation?

Can you run the upgrade “manually” with apt-get update && apt-get dist-upgrade ?

I would like to avoid to run command directly from the server.

I would like to perform the update directly from the Yunohost’s interface. If this is a bug from Yunohost, is there an explanation / walk-around ?

In last case, I will upgrade from the server.

Thank you for your feedback.

Is there any explanation to this behaviour?

Y a-t-il une explication à propos de cette anomalie ?

Maybe the upgrade is not yet finished ? Internet cube with Lime1 are slow (512MB of ram…).

Or maybe, the others packages upgrade took more than 1 hour, and when the cron task has tried to run the upgrade of ssowat, yunohost-admin and moulinette package, the apt process was already in use… In this case the upgrade is reported to the next hour.

Note the upgrade attempt of these packages is run at each start of hour

You can check that by searching if an apt process is running:

ps aux | grep apt

And by test if the cron file is still present:

ls /etc/cron.d/yunohost-upgrade

Thank you @ljf for your feedback.
I have tried your two commands provided.

The first one returns a line ending by :
grep apt

I am supposing it is the line of my command.

Furthermore (about your 2nd command), there is no file as :
Actually there is only the following one about Yunohost :

Should I suppose then that there is no upgrade process running on my machine?
In consequence, that would mean there is a malfunction somewhere in the upgrade process.

If yunohost --version is not 2.7.5, yes there is a malfunction.

$ yunohost --version
yunohost: 2.7.5
yunohost-admin: 2.7.5
moulinette: 2.7.5
ssowat: 2.7.5

I have in consequence done the manual upgrade from the server (after ssh connection) :
apt-get update
apt-get upgrade

However, when the following lines appears :
Préparation du dépaquetage de .../git_1%3a2.1.4-2.1+deb8u5_armhf.deb ...
Dépaquetage de git (1:2.1.4-2.1+deb8u5) sur (1:2.1.4-2.1+deb8u4) ...
Préparation du dépaquetage de .../hostapd_1%3a2.3-1+deb8u5_armhf.deb ...
I lost the connection (I was connected to internet using wireless through the internet cube / la brique internet)

Through the following link https://[my-sub-domain] I have the following services inactive: php-fpm and nsswitch. Is that normal?

Furthermore, where I am trying to reach the following pages:

  • https://[my-sub-domaine]
  • https://[my-sub-domaine]

I get the following error message :

502 Bad Gateway

Thank you for your support.

apt-get upgrade is not enough, you need to run apt-get dist-upgrade as Aleks said.

php5-fpm should be started. nnswitch i don’t know exactly.

Hello all,
I connected to my server (to my Internet Cube through my LAN network as my wireless connection was broken), and I performed the command :
apt-get dist-upgrade

I got the following result :
# apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Is that normal that nothing new was supposed to be upgraded?

So I decided to reboot my server. I performed the following command :
Was it correct? isn’t it too ‘violent’ to reboot properly a server?

Now, everything is working :

  • I can reach the following pages without error
    • https://[my-sub-domaine]
    • https://[my-sub-domaine]
  • the php-fpm service is running (although nsswitch is still inactive)

Should I still perform the initial command :
apt-get dist-upgrade
If yes, why should I?

Thank you in advance for your explanations, which help me to better understand the ecosystem :slight_smile:

Hi @ljf , hi @Aleks,
are you available to clear my mind regarding my last post?

Is it maybe better to write in French here to expect receiving more feedback?

In any case thank’s for your work / support.

Hi @jef

Nope, especially since we’re trying to not look “too french” to not make non-french people run away :stuck_out_tongue: It’s okay to re-poke people in case you’re waiting to long for an answer :wink:

Maybe :sweat_smile: Does yunohost --version correctly shows 2.7.x now ? If not, can you make sure that you did an apt-get update before ?

I suppose it’s a bit violent, but not as bad as people would think I guess ¯\(ツ)/¯. However, in the Linux world, you should be aware that rebooting the machine to attempt to magically solve issues (like a lot of people do, due to previous experiences in the Windows world) is usually not necessary / not the right way to proceed :sweat_smile: .

Well if everything is working, I guess you shouldn’t :stuck_out_tongue: Though you shoud definitely check the yunohost version to make sure everything is alright :ok_hand:

Yes ! :stuck_out_tongue:

Is there any other way to softly reboot a server?

In my case, how could I make my services work again after the
apt-get upgrade (without rebooting)? I was indeed unable to access these pages:

  • https://[my-sub-domaine]
  • https://[my-sub-domaine]

Hmm :thinking:, well I’m not sure, but from what I understand if was the php-fpm service that was stopped, so to restart it you might/could have done something like :

systemctl php5-fpm restart

Yeah, ok, I will keep that in mind :wink:

Good to learn indeed!