Reinstalled Nextcloud - Nextcloud Clients Won't Connect

I had a Nexcloud installation working with the Nextcloud Linux and Android clients.
I had to reinstall my server.
I did a fresh install of Nextcloud.

Now, Nextcloud works in the browser but the Linux and Android client won’t connect.

I am trying to add a server account like this: https://domain.tld/nextcloud

On the Android Client it says “Malformed Server Configuration”
On the Linux Appimage it says “Failed to connect. Unknown Error.”

If I try to add the account:
I get an SSL certificate error of course.

### Cannot connect securely to
The host name did not match any of the valid hosts for this certificate
The issuer certificate of a locally looked up certificate could not be found
No certificates could be verified
### with Certificate
  • I tried deleting the ~/.config/Nextcloud and ~/.cache/Nextcloud folders
  • I tried re-downloading the Linux Appimages
  • I tried re-installing the Android client

Anybody have the issue before? or have some ideas of what I can try?

PS I didn’t post this under Support because this seems to be more about the Nextcloud Clients and not Yunohost.

Did you add visitors permission to nextcloud and nextcloud api?

1 Like

Ah. During the install it asked something like that. I think I said no.

Ok. I need to figure out how to add that back, or at this point I could just reinstall nextcloud.

This is a new option. They didn’t have it 2 years ago when I installed it.

Choose the domain where this app should be installed [domain.tld]: domain.tld
Choose the URL path (after the domain) where this app should be installed: /nextcloud
Choose an administrator user for this app [bob]: bob
Should this app be exposed to anonymous visitors? [yes | no]: yes
Access the users home folder from Nextcloud? [yes | no]: no

Ok I tried saying ‘yes’ to anonymous visitors. That sounded scary so I didn’t choose it before.

In the webadmin : users>permissions>visitors : add nc and nc api.
With a good password and system up to date, it’s OK. You can use apps passwords for nc (find it in settings, I think in the bottom)

1 Like