Redmine email notify settings

Hello. have a good day.

  • Hardware: VPS.
  • YunoHost version: 4.3.6.3
  • I have access to my server: Through SSH

i install the app(redmine) with webadmin, there is no any errors or issue.
next step i configure email notification in settings. and try to send test email and get error:
An error occurred while sending mail (hostname “localhost” does not match the server certificate)
i see the manual in official redmine site.
and i go to ssh and copy the etc/yunohost/apps/redmine/conf/configuration.yml.example
to
etc/yunohost/apps/redmine/conf/configuration.yml
make a settings with:
default:
email_delivery:
delivery_method: :smtp
smtp_settings:
address: “foo@foo.com
port: 25
or
email_delivery:
delivery_method: :smtp
smtp_settings:
address: “example.com
port: 25
authentication: :login
domain: ‘foo.com
user_name: ‘myaccount’
password: ‘password’

after i try to use systemd to restart redmine service.(and try reboot server also)
there is no effect which settings in config.
im always get error (An error occurred while sending mail (hostname “localhost” does not match the server certificate)
any help please?

Try something like that :

email_delivery:
    delivery_method: :smtp
    smtp_settings:
      enable_starttls_auto: true
      address: "yourdomain.tld" 
      port: 587
      domain: "yourdomain.tld" 
      authentication: :plain
      user_name: "your_username" 
      password: "your_password" 

More info here → Configuring email client | Yunohost Documentation

Thank you for answer. I do changes in /etc/yunohost/apps/redmine/conf/configuration.yml
and do systemctl restart redmine and nothing. get the same error. maybe redmine in yunohost use another config? or i dont know… i try to do this 3 days…