Raspberry Pi & fichier /etc/hosts

,

Salut,

Je viens de remarquer quelque chose d’étrange dans le fichier /etc/hosts sur raspberry. En effet, la ligne suivante était absente =

The following lines are desirable for IPv6 capable hosts

::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Cela avait pour conséquence un ralentissement de la connexion.
Autre bizarrerie : si l’on modifie ce qu’il y a après 127.0.1.1 (et qu’on enlève raspberry ou yunohost sur la ligne), on ne peut plus se connecter en SSH avec Putty !

Je reviens vers vous pour en savoir plus : j’ai modifié mon fichier /etc/hosts de la façon suivante =

127.0.0.1 localhost
192.168.1.50 blabla.com *
[adresse ip externe] blabla.com * => ajouté dans un second temps

J’ai ensuite redémarré. Je constate des accélérations quand j’accès aux pages du site, cependant si je tente d’accéder au SSH ou bien que je tente de mettre à jour, rien ne se passe, et une erreur est retournée (le serveur n’arrive pas à se connecter aux serveurs de mises-à-jour).
Quelqu’un peut-il m’éclairer sur ce sujet ?

Merci !

Sous RaspberryPI
*fichier /etc/hosts:

127.0.0.1 localhost
127.0.1.1 raspberrypi

  • fichier /etc/apt/sources.list :

deb http://mirrordirector.raspbian.org/raspbian jessie main non-free
deb http://archive.raspberrypi.org/debian jessie main
deb http://repo.yunohost.org/ stable/rpi main

Normalement l IPV6 est active sur le rom raspbian pour Yunohost.
Pour activer celle-ci sur ta raspi
:blush:
Enable the IPv6 kernel module by typing this in your shell:

  • sudo modprobe ipv6

Now, enable IPv6 by default after boot:

  • sudo echo “ipv6” >> /etc/modules

If needed, adjust your network configuration file by adding IPv6 here. Options are auto or dhcp. In my case, the modem acts as an IPv6 router (XS4ALL fiber). So adding this to the network options enabled DHCP:

  • sudo echo “iface eth0 inet6 dhcp” >> /etc/network/interfaces

Now reboot with:

  • sudo shutdown -rf now

The IPv6 is already activated, I checked a few days ago in /etc/modules/

The issue came from my DNS server on the routeur since I changed the DNS in dhclient. But the DNS names in the router weren’t the same as those in dhclient.

And now, because of this command : sudo echo “iface eth0 inet6 dhcp” >> /etc/network/interfaces, my server crashed…