Raspberry Pi 3 & no boot

Hello :smile:

I have an issue when I try to boot from the Raspberry Pi 3 with the existing IMG file for versions 1 & 2. It doesn’t boot when I switch on the Rasp. And it is currently not possible to download the image from the site.

Same issue for me, it’s blocked on the first screen with the coloured test pattern.
I also tried to install it from a working debian, but the installation failed (seems like it’s a know error).

But I don’t understand why the images’ sources on build.yunohost.org aren’t no more accessible for a while… It would be fine to know when a relase compatible with the newest Raspberry Pi is available.

Those images are from July 2015.
We might ask some dev’ to know when they plan to release a new one for Rpi 3, or how we can build one.

Wheezy image for Raspberry Pi 1 and 2 created the 4th june 2015. It’s just for 1 AND 2.
About Pi 3, the kernel rpi 3 is different from previous.

We must use the last image (JESSIE image lite https://www.raspberrypi.org/downloads/raspbian/ )
Installation steps

  1. Copy image to the SD card
  2. Plug & boot
  3. Post-install

Recommended after post-installation
Connect via SSH: root@IP.OF.RPI (password: yunohost)Change root password: passwd rootUpgrade system: apt-get update && apt-get dist-upgrade && rpi-update

NB: https://github.com/YunoHost/doc/blob/master/install_on_raspberry.md

Up. Still no image for the raspberry 3 on the official site. Also impossible to install it from debian (the installation script fail, yunohost-config-dovecot is not configured correctly).
How can we create an image / install yunohost on a raspberry 3 ?

It would be nice to tell us how we can install Yunohost on the 3th edition…

1 Like

Hello, I’ve struggled with installation tonight on a new Raspberry Pi 3, and I faced the same problem than you.

The problem from my side was that the domain name wasn’t configured correctly, because the RPI3 comes with a raspberry default hostname which is not compliant with amavisd-new's configuration since it expects a fully qualified name such as: yunohost.yunohost.org.
This name should be set by the install script, but it is not used until a RPI reboot. I changed the hostname accordingly, I rebooted and I relaunched the installation of amavisd-new, then I recloned the git repo because of /tmp had been erased, and finally relaunched the yunohost installation script, but this time without using the -d positional argument in order to track what occured.

Now I’m ready to launch post-installation step.

I figured out by looking at journalctl -xn output when trying to manually install the amavisd-new package:
As root:
dpkg --configure amavisd-new #-> failed
journalctl -xe

Hope this helps.

I will try to install it again, with the version 2.4, and if it works I will prepare an image for RPi 3 :wink:

Thank you soo much

Ok I just installed the v2.4 with this guide (in fr) http://avignu.wiki.tuxfamily.org/doku.php?id=documentation:yunohost-jessie

No issue with moulinette, unlike the guide says, so I suppose this issue is corrected :slight_smile:

So maybe the install script is working, can you try it ?