What type of hardware are you using: VPS bought online
What YunoHost version are you running: 12.0.17
What app is this about: Question2Answer
Describe your issue
I’ve just installed the Question2Answer app, so far so good. But when I try to login to the admin interface as set in the setup page, the app returns the error 500. When I check the nginx log I see an Call to undefined function ldap_connect() error thrown.
I checked if there is a reported issue and found one but without response:
Could you guys please recommend a remedy for this? Thank you!
Share relevant logs or error messages
2025/07/22 17:17:23 [error] 559844#559844: *4127 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Call to undefined function ldap_connect() in /var/www/question2answer/qa-plugin/qa-ldap-login/LDAPServer.php:10
Stack trace:
#0 /var/www/question2answer/qa-plugin/qa-ldap-login/qa-ldap-process.php(36): LDAPServer->connectWithServer()
#1 /var/www/question2answer/qa-plugin/qa-ldap-login/qa-ldap-process.php(58): ldap_process()
#2 /var/www/question2answer/qa-include/pages/login.php(62): require_once('...')
#3 /var/www/question2answer/qa-include/app/page.php(183): require('...')
#4 /var/www/question2answer/qa-include/qa-page.php(47): qa_get_request_content()
#5 /var/www/question2answer/qa-include/qa-index.php(189): require('...')
#6 /var/www/question2answer/index.php(27): require('...')
#7 {main}
thrown in /var/www/question2answer/qa-plugin/qa-ldap-login/LDAPServer.php on line 10" while reading response header from upstream, client: 212.253.8.111, server: ****************, request: "POST /q2a/index.php/login?to=index.php%2Fadmin HTTP/2.0", upstream: "fastcgi://unix:/var/run/php/php8.0-fpm-question2answer.sock:", host: "****************", referrer: "https://****************/q2a/index.php/login?to=index.php%2Fadmin"