Problems on nextcloud update

Hello, today I updated yunohost without a problem, right after that tried to update nextcloud but unfortunately got this error: Source path '/etc/logrotate.d/nextcloud' does not exist, full log at

Please help?

Very weird…
Can you please execute sudo touch /etc/logrotate.d/nextcloud and retry the upgrade?

Thanks for trying to help. Created the file following your suggestion and tryed a new upgrade. Seems like the same problem:

Very weird, indeed!
Does the file exist and what are the permissions on it?

Jimbojoe, made a mistake on my side, creating the files under /etc/logrotate.d and after at /etc/cron.d solved these errors.
Now this is the last error I can’t handle:

    2018-09-19 01:21:05,809 WARNING  yunohost.hook <lambda> - [30947.12] The output directory is not empty
    2018-09-19 01:21:05,811 WARNING  yunohost.hook <lambda> - [30947.12] Backup failed, the upgrade process was aborted.

Could you please clean the /home/yunohost.backup/tmp directory and retry?

Done it.
Now I get a API is not responding message on the top notification bar which follows the message Data dir will not be saved, because backup_core_only is set., and that’s all, there are any further logs.


I guess the upgrade process is still ongoing (Nextcloud backup can be very long, depending on the amount of data!)…
I think you can see that in /var/log/yunohost/yunohost-cli.log.

Wow this is a big and daunty log… I searched from the end backwards for nextcloud and made the cut from there OK, let me know if another strategy for this is relevant.

Unfortunately the update did not finish, and FYI, after some seconds of update I get logged out of yunohost and must log in again. Maybe this error message has something to do with it?

The log excerpt unfortunately doesn’t include the nextcloud upgrade…
Can you maybe retry the upgrade from the CLI?

And it just worked!
You tha man! Thanks a lot…
Logs as usual:

1 Like