Problème pour faire la mise à jour de Yunohost [résolu]

,

Bonjour à tous,
Voici le message que j’ai lorsque je souhaite faire la mise à jour de Yunohost :confused:
Je n’arrive pas à comprendre le message, comme il est indiqué sur le message d’erreur, je passe par le forum pour trouver de l’aide :blush:

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 9.6 (stretch)
Release: 9.6
Codename: stretch

yunohost --version
yunohost:
repo: now
version: 3.2.2
yunohost-admin:
repo: now
version: 3.2.1
moulinette:
repo: now
version: 3.2.0
ssowat:
repo: now
version: 3.2.0


**YunoHost a rencontré une erreur interne **
Vraiment navré.
Vous devriez chercher de l’aide sur le forum ou le salon pour résoudre le problème, ou rapporter le bogue sur l’outil de suivi.

Les informations suivantes peuvent être utile à l’interlocuteur vous aidant :

Action

GET /diagnosis {“locale”:“fr”}

Trace

Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/moulinette/interfaces/api.py”, line 406, in process
ret = self.actionsmap.process(arguments, timeout=30, route=_route)
File “/usr/lib/python2.7/dist-packages/moulinette/actionsmap.py”, line 498, in process
return func(**arguments)
File “/usr/lib/moulinette/yunohost/tools.py”, line 621, in tools_diagnosis
services = service_status()
File “/usr/lib/moulinette/yunohost/service.py”, line 237, in service_status
status = _get_service_information_from_systemd(name)
File “/usr/lib/moulinette/yunohost/service.py”, line 300, in _get_service_information_from_systemd
service_path = manager.GetUnit(service + “.service”)
File “/usr/lib/python2.7/dist-packages/dbus/proxies.py”, line 70, in call
return self._proxy_method(*args, **keywords)
File “/usr/lib/python2.7/dist-packages/dbus/proxies.py”, line 145, in call
**keywords)
File “/usr/lib/python2.7/dist-packages/dbus/connection.py”, line 651, in call_blocking
message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Salut,

est-ce que tu peux préciser à quel moment exactement tu as rencontré ce probleme ? Est-ce que c’est directement en te connectant à la webadmin ? Ou bien c’est vraiment une fois la mise à jour lancée ?

hello,
c’est en cliquant sur “mettre à jour le système” dans la webadmin
(et services

ça a fini par m’afficher la page avec liste des paquets à mettre à jour
mais la mise à jour plante :confused:

https://paste.yunohost.org/iratoculup

Hmokay mais est-ce que tu aurais le “vrai” log de mise à jour ? (Dans Outils > Logs > [le_log_qui_va_bien] > Bouton Partager avec YunoPaste ?)

Sinon, est-ce que tu arrives à faire la mise à jour depuis la ligne de commande avec apt update && apt dist-upgrade ?

le voici, il me semble mince en info
https://paste.yunohost.org/raw/oyokaxedot

Calcul de la mise à jour… Fait
Les paquets suivants seront mis à jour :
dirmngr dnsmasq dnsmasq-base firmware-amd-graphics firmware-atheros firmware-libertas firmware-linux-nonfree firmware-misc-nonfree firmware-realtek fuse gnupg gnupg-agent gnupg-l10n gnupg2
gpgv hostapd libcurl3-gnutls libfuse2 libgnutls-openssl27 libgnutls30 libmariadbclient18 libunbound2 libxcursor1 linux-image-4.9.0-8-armmp linux-libc-dev mariadb-client-10.1 mariadb-server
mariadb-server-10.1 mariadb-server-core-10.1 metronome opensc opensc-pkcs11 publicsuffix tzdata
34 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
37 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/66,2 Mo dans les archives.
Après cette opération, 556 ko d’espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets…
(Lecture de la base de données… 66385 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de …/metronome_3.11.1+yunohost-1_armhf.deb …
Failed to reload daemon: Connexion terminée par expiration du délai d’attente
Failed to retrieve unit: Connexion terminée par expiration du délai d’attente
Failed to stop metronome.service: Connexion terminée par expiration du délai d’attente
See system logs and ‘systemctl status metronome.service’ for details.
Failed to get load state of metronome.service: Connexion terminée par expiration du délai d’attente
invoke-rc.d: initscript metronome, action “stop” failed.
dpkg: avertissement: le sous-processus ancien script pre-removal a retourné une erreur de sortie d’état 1
dpkg: tentative d’exécution du script du nouveau paquet à la place…
Failed to reload daemon: Connexion terminée par expiration du délai d’attente
Failed to retrieve unit: Connexion terminée par expiration du délai d’attente
Failed to stop metronome.service: Connexion terminée par expiration du délai d’attente
See system logs and ‘systemctl status metronome.service’ for details.
Failed to get load state of metronome.service: Connexion terminée par expiration du délai d’attente
invoke-rc.d: initscript metronome, action “stop” failed.
Progression : [ 0%] […] ost-1_ProProgProgreProgression : [ 0%] […]
Progression : [ 0%] […]
Progression : [ 0%] […Progression : [ 0%] […Progression : [ 0%] […Progression : [ 0%] […Failed to reload daemon: Connexion terminée par expiration du délai d’attente]
Failed to retrieve unit: Connexion terminée par expiration du délai d’attente
Failed to start metronome.service: Connexion terminée par expiration du délai d’attente
See system logs and ‘systemctl status metronome.service’ for details.
invoke-rc.d: initscript metronome, action “start” failed.
Failed to get properties: Connexion terminée par expiration du délai d’attente
dpkg: error while cleaning up:
le sous-processus script post-installation installé a retourné une erreur de sortie d’état 1
Des erreurs ont été rencontrées pendant l’exécution :
/var/cache/apt/archives/metronome_3.11.1+yunohost-1_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Does yunohost --version still shows 3.2, or are you in 3.3 now ?

voici :

yunohost --version
yunohost:
repo: stable
version: 3.3.1
yunohost-admin:
repo: stable
version: 3.3.1
moulinette:
repo: stable
version: 3.3.1
ssowat:
repo: stable
version: 3.3.1

Alrighty, du coup si tu fais un yunohost service regen-conf metronome --force puis que tu retentes apt-get dist-upgrade, est-ce que ça va mieux ?

yunohost service regen-conf metronome --force
Succès ! La configuration a été mise à jour pour le service « metronome »
Attention : Failed to retrieve unit: Connexion terminée par expiration du délai d’attente
Attention : Failed to restart metronome.service: Connexion terminée par expiration du délai d’attente
Attention : See system logs and ‘systemctl status metronome.service’ for details.
Erreur : Échec de l’exécution du script « /usr/share/yunohost/hooks/conf_regen/12-metronome »
metronome:
applied:
/etc/metronome/metronome.cfg.lua:
status: force-updated
pending:

Hmokay, et du coup que raconte systemctl status metronome ?

:sweat:

systemctl status metronome
Failed to get properties: Connexion terminée par expiration du délai d’attente

Zblerg

Est-ce que faire

systemctl --force --force reboot

résoud le problème ? (genre est-ce que tu arrives à faire systemctl status metronome ensuite ?)

voici

systemctl status metronome
● metronome.service - LSB: Metronome XMPP Server
Loaded: loaded (/etc/init.d/metronome; generated; vendor preset: enabled)
Active: active (running) since Wed 2018-11-28 22:22:53 CET; 21s ago
Docs: man:systemd-sysv-generator(8)
Process: 554 ExecStart=/etc/init.d/metronome start (code=exited, status=0/SUCCESS)
Tasks: 1 (limit: 4915)
CGroup: /system.slice/metronome.service
└─889 lua5.1 /usr/bin/metronome

Wokay, ça s’annonce déjà mieux …

Du coup, est-ce que apt dist-upgrade fonctionne maintenant ?

oui :slight_smile:
j’essaie de suite

c’est en cours (87%)
que me conseilles-tu ici ?

Fichier de configuration « /etc/metronome/metronome.cfg.lua »
==> Modifié (par vous ou par un script) depuis l’installation.
==> Le distributeur du paquet a fourni une version mise à jour.
Que voulez-vous faire ? Vos options sont les suivantes :
Y ou I : installer la version du responsable du paquet
N ou O : garder votre version actuellement installée
D : afficher les différences entre les versions
Z : suspendre ce processus pour examiner la situation
L’action par défaut garde votre version actuelle.
*** metronome.cfg.lua (Y/I/N/O/D/Z) [défaut=N] ?

Appuie juste sur Entrée pour garder l’option par défaut (N)

ok, merci

@Aleks

All packages are up to date

un grand merci ! :love_letter:

as-tu une explication à ce problème, j’aimerai comprendre

1 Like