Problème de migration postgresql_9p6_to_11.py

Bonjour,
Tout c’est bien passé pendant la migration en Buster excepté la mise à jour de postgresql:

ended_at: 2020-07-30 15:27:32.562324
error: “La migration 0017_postgresql_9p6_to_11 a \xE9chou\xE9 avec l\u2019exception
\ PostgreSQL 9.6 is installed, but not postgresql 11\u203D Something weird might
\ have happened on your system :(… : annulation”
operation: tools_migrations_migrate_forward
started_at: 2020-07-30 15:27:32.395334
success: false
yunohost_version: 4.0.3

============

2020-07-30 17:27:32,413: INFO - Exécution de la migration 0017_postgresql_9p6_to_11…
2020-07-30 17:27:32,560: ERROR - La migration 0017_postgresql_9p6_to_11 a échoué avec l’exception PostgreSQL 9.6 is installed, but not postgresql 11‽ Something weird might have happened on your system :(… : annulation
Traceback (most recent call last):
File “/usr/lib/moulinette/yunohost/tools.py”, line 899, in tools_migrations_migrate
migration.run()
File “/usr/lib/moulinette/yunohost/data_migrations/0017_postgresql_9p6_to_11.py”, line 26, in run
raise YunohostError(“migration_0017_postgresql_11_not_installed”)
YunohostError: PostgreSQL 9.6 is installed, but not postgresql 11‽ Something weird might have happened on your system :(…

Pourriez-vous m’aider?
En vous remerciant

Salut,

pas sur de pourquoi ça se produit mais à mon avis tu peux faire un

apt install postgresql postgresql-11

et retenter la migration

Merci

salut j ai le meme pb apt install postgresql postgresql-11n a pas résolu le probleme.
https://paste.yunohost.org/raw/nayiluqifi

1 Like