Probleme de locales

setlocale
locales
fr

#1

Bonsoir,

Comme j’avais un peu trop bidouillé ma précédente installation je me suis mis en quette de tout refaire.
Donc après 2 installation consécutives de yunohost 3.1.0 (pourquoi on peut pas telecharger directement la 3.2 ?) sur mon Raspi 3B+ ça fonctionne à peu près mais y’a un truc bizarre quand je me log en ssh j’ai ça :

-bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

sauf que c’est apparu tout le temps quand j’ai fait les mises à jour avec un gros WARNING.
En plus si je me met avec un clavier directe sur mon RPi c’est du qwerty :hot_face:

Bref je voudrais savoir quel est mon problème surtout que je ne l’avait pas avant. (A savoir que configurer directement les locale dans raspi-config ne règle rien…
Merci d’avance et bravo pour ce que vous faites !


#2

Bonjour @LaBaude ,

Sûrement quelques informations ici qui devraient pouvoir t’aider avec raspi-config :
https://avignu.wiki.tuxfamily.org/doku.php?id=documentation:yunohost-stretch-v3.x.x.x-rpi#configuration_de_raspbian_lite_stretch

ppr


[Contributors meeting] September 18th, 2018
#3

Okok merci @ppr je vais regarder ça … Je précise que j’ai utilisé l’image yunohost… donc je trouve ça étrange de devoir configurer ça… surtout que comme je l’ai dis ça ne m’étais pas arrivé la 1ere fois…


#4

Salut,

Pas vraiement besoin de raspi-config, quoi qu’il aide pas mal.
Théoriquement les commande suivantes suffisent.

locale-gen en_US.UTF-8
dpkg-reconfigure locales

#5

Salut !
Merci pour vos réponses !
Malheureusement aucune des solutions ne fonctionne.
@ppr c’est ce que j’avais fais.
@gannonwoto ça ne fonctionne malheureusement pas :

-bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
-bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
root@labaudesrv:~# locale-gen en_US.UTF-8
Generating locales (this might take a while)...
  fr_FR.UTF-8... done
Generation complete.
root@labaudesrv:~# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = "en_US.UTF-8",
        LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("fr_FR.UTF-8").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or director                                                                                                                                                             y
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or direc                                                                                                                                                             tory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)...
  fr_FR.UTF-8... done
Generation complete.

#6
        LANGUAGE = (unset),
        LC_ALL = "en_US.UTF-8",
        LANG = "fr_FR.UTF-8"

???
Bon, retourne dans raspi-config ou dpkg-reconfigure locales, désélectionne fr_FR.UTF-8 pour ne laisser que en_US.UTF-8.


Données remontées quotodiennement
#7

Bonjour,

Lorsque j’ai eut ce problème je suis tombé sur cela, peut être cela pourra aider : https://perhonen.fr/blog/2016/07/yocto-2854


#8

Bonjour,

Merci, par contre je n’ai pas trouvé où modifier le paramètre “Language=(unset)”
Comment le passer sur la langue choisie?