Probleme d'accès au web au travers de la brique

Bonjour @tous,

Mon serveur YunoHost

Matériel: Brique Internet avec VPN
Version de YunoHost:

L’architecture du serveur est bare-metal armhf

Le modèle du serveur est Olimex A20-OLinuXino-LIME

Le serveur utilise le noyau Linux 4.19.62-sunxi
Le serveur utilise Debian 10.8
Le serveur utilise YunoHost 4.1.7.1 (stable)

yunohost version : 4.1.7.1 (stable)
yunohost-admin version : 4.1.4 (stable)
moulinette version : 4.1.4 (stable)
ssowat version : 4.1.3 (stable)

J’ai accès à mon serveur : En SSH | Par la webadmin

Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Plus d’accès internet au travers de la brique différent retour de diagnostic depuis hier soir voir les différentes choses qui suivent:

lien yunopaste pour la partie web:
https://paste.yunohost.org/raw/naxucusito

Retour de ce matin:

Internet connectivity (ip)

[WARNING] The server does not have working IPv6.

  • Having a working IPv6 is not mandatory for your server to work, but it is better for the health of the Internet as a whole. IPv6 should usually be automatically configured by the system or your provider if it’s available. Otherwise, you might need to configure a few things manually as explained in the documentation here: YunoHost • index. If you cannot enable IPv6 or if it seems too technical for you, you can also safely ignore this warning.

Dans la configuration du dns de mon domaine recommandée dans yunohost plus aucune adresse ipv6 n’ai proposer alors qu’habituellement il y a toujours l’adresse qui m’a été donnée avec mon vpn.

Donc aucun accès à partir du hotspot de la brique vers internet au travers du vpn.
Mais j’ai accès à ma brique à distance en ssh et au travers de la webadmin.

Je ne vois pas très bien quoi faire pour essayer de remettre tout en état de fonctionnement.

D’avance je vous remercie pour vos idées et votre aide.

Bonne ournée @tous.

didier58

Que dit ip a actuellement sur le serveur ?

Que donne un traceroute -6 wikipedia.org sur la machine connectée au hotspot wifi ?

Salut @ljf,

voila le retour de ip a:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: dummy0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether ee:d6:b6:dc:3e:35 brd ff:ff:ff:ff:ff:ff
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 02:41:05:c2:b0:81 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.23/24 brd 192.168.1.255 scope global dynamic eth0
valid_lft 51748sec preferred_lft 51748sec
inet6 fe80::42:acab/128 scope link
valid_lft forever preferred_lft forever
inet6 fe80::41:5ff:fec2:b081/64 scope link
valid_lft forever preferred_lft forever
4: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 02:de:d0:16:3a:00 brd ff:ff:ff:ff:ff:ff
inet 10.0.242.1/24 scope global wlan0
valid_lft forever preferred_lft forever
inet6 2a00:5881:8118:400::42/64 scope global
valid_lft forever preferred_lft forever
inet6 fe80::de:d0ff:fe16:3a00/64 scope link
valid_lft forever preferred_lft forever
5: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
link/ether 02:42:d9:a9:39:15 brd ff:ff:ff:ff:ff:ff
inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
valid_lft forever preferred_lft forever
6: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
link/none
inet 89.234.141.4/26 brd 89.234.141.63 scope global tun0
valid_lft forever preferred_lft forever
inet6 2a00:5881:8118:400::42/128 scope global
valid_lft forever preferred_lft forever
inet6 2a00:5881:8100:100::4/64 scope global
valid_lft forever preferred_lft forever
inet6 fe80::78a5:8c36:2dec:26d9/64 scope link stable-privacy
valid_lft forever preferred_lft forever

et pour traceroute -6 wikipedia.org:
traceroute to wikipedia.org (2620:0:862:ed1a::1), 30 hops max, 80 byte packets
1 vpn-end.arn-fai.net (2a00:5881:8100:100::1) 10.958 ms 11.485 ms 11.283 ms
2 hwhost-2.arn-fai.net (2a00:5881:8100::132) 11.361 ms 11.689 ms 11.945 ms
3 tunnel558968.tunnel.tserv17.lon1.ipv6.he.net (2001:470:11:d::1) 28.409 ms 28.897 ms 29.173 ms
4 ve108.core1.lon2.he.net (2001:470:0:3b0::1) 28.501 ms 28.839 ms 28.598 ms
5 * e0-30.core2.lon3.he.net (2001:470:0:3ea::2) 29.732 ms *
6 e0-32.core2.ams2.he.net (2001:470:0:489::2) 29.636 ms 30.340 ms 29.133 ms
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *

didier58

Salut @ljf,

pour traceroute -6 wikipedia.org je me suis trompé c’est celui du serveur que je t’ai envoyer voici le bon:

traceroute to wikipedia.org (2620:0:862:ed1a::1), 30 hops max, 80 byte packets
1 didiercl.me (2a00:5881:8118:400::42) 5.526 ms 5.473 ms 5.302 ms
2 vpn-end.arn-fai.net (2a00:5881:8100:100::1) 13.640 ms 14.283 ms 14.266 ms
3 hwhost-2.arn-fai.net (2a00:5881:8100::132) 15.006 ms 14.995 ms 14.966 ms
4 tunnel558968.tunnel.tserv17.lon1.ipv6.he.net (2001:470:11:d::1) 31.355 ms 31.419 ms 31.279 ms
5 ve108.core1.lon2.he.net (2001:470:0:3b0::1) 31.249 ms 31.238 ms 31.164 ms
6 * * e0-30.core2.lon3.he.net (2001:470:0:3ea::2) 30.726 ms
7 e0-32.core2.ams2.he.net (2001:470:0:489::2) 31.540 ms 32.875 ms 32.688 ms
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *

Bonne journée ensoleiller @toi.

didier58

Salut @Didier58,

Et ça donne quoi ping6 wikipedia.fr sur le serveur et sur la machine connectée ?

Salut @Ljf,

le ping6 wikipedia.fr sur le pc connecté:
~ ping6 wikipedia.fr
PING wikipedia.fr(2001:41d0:302:2100::9ee (2001:41d0:302:2100::9ee)) 56 data bytes
64 octets de 2001:41d0:302:2100::9ee (2001:41d0:302:2100::9ee) : icmp_seq=1 ttl=50 temps=42.3 ms
64 octets de 2001:41d0:302:2100::9ee (2001:41d0:302:2100::9ee) : icmp_seq=2 ttl=50 temps=37.0 ms

et pour le serveur:

$ ping6 wikipedia.fr
PING wikipedia.fr(2001:41d0:302:2100::9ee (2001:41d0:302:2100::9ee)) 56 data bytes
64 bytes from 2001:41d0:302:2100::9ee (2001:41d0:302:2100::9ee): icmp_seq=1 ttl=51 time=35.0 ms
64 bytes from 2001:41d0:302:2100::9ee (2001:41d0:302:2100::9ee): icmp_seq=2 ttl=51 time=33.7 ms
64 bytes from 2001:41d0:302:2100::9ee (2001:41d0:302:2100::9ee): icmp_seq=3 ttl=51 time=33.8 ms

Voila les deux retours.

didier58

Donc là ton ipv6 fonctionne sur les 2 équipements.

J’ai cherché un peu et visiblement c’était un problème temporaire avec HE londre, on peut le voir sur le graph IPv6 d’ARN.

https://smokeping.illyse.org/?target=ISP.FFDN.ARN_v6

Salut @Ljf,

Merci pour le retour,effectivement pour l’ipv6 tout à l’air d’être rentrer dans l’ordre mais pour l’ipv4 cela n’a pas l’air de fonctionner en testant avec ip.yunohost.org retour: Le délai d’attente est dépassé
pour ip6.yunohost.org pas de problème l’adresse s’affiche bien.
Mais énormément de sites sont inaccessibles aucune consultation possible au travers du vpn
Alors que diagnostic ne retourne aucune erreur ci-joint le lien yunopaste:

https://paste.yunohost.org/raw/gahifihage

La seule différence que je trouve dans diagnostic c’est dans connectivité internet ou l’ipv4 l’adresse local est différente de la global ce qui n’était pas le cas jusqu’à présent et qui n’est pas le cas en ipv6 ou c’est la même adresse en local qu’en global.
Je suis toujours dans l’impasse pour l’utilisation du vpn.

Si tu as une idée tiens moi au courant.

Bonne journée à toi.

didier58

Que donne ?

ping -4 ip.yunohost.org

Salut @Ljf,

Le retour de ping -4 ip.yunohost.org est le suivant:

➜ ~ ping -4 ip.yunohost.org

PING ip.yunohost.org (80.67.172.144) 56(84) bytes of data.

Aucun retour.

Rien ne ce passe.

didier58

Que donne sur le serveur :

ip a

Y a t’il une ipv4 publique sur tun0 ?

Voila le retour:
$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: dummy0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 56:f2:17:c9:d8:bc brd ff:ff:ff:ff:ff:ff
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 02:41:05:c2:b0:81 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.23/24 brd 192.168.1.255 scope global dynamic eth0
valid_lft 62086sec preferred_lft 62086sec
inet6 fe80::42:acab/128 scope link
valid_lft forever preferred_lft forever
inet6 fe80::41:5ff:fec2:b081/64 scope link
valid_lft forever preferred_lft forever
4: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 02:de:d0:16:3a:00 brd ff:ff:ff:ff:ff:ff
inet 10.0.242.1/24 scope global wlan0
valid_lft forever preferred_lft forever
inet6 2a00:5881:8118:400::42/64 scope global
valid_lft forever preferred_lft forever
inet6 fe80::de:d0ff:fe16:3a00/64 scope link
valid_lft forever preferred_lft forever
5: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
link/ether 02:42:b8:e4:e7:cf brd ff:ff:ff:ff:ff:ff
inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
valid_lft forever preferred_lft forever
6: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
link/none
inet 89.234.141.4/26 brd 89.234.141.63 scope global tun0
valid_lft forever preferred_lft forever
inet6 2a00:5881:8118:400::42/128 scope global
valid_lft forever preferred_lft forever
inet6 2a00:5881:8100:100::4/64 scope global
valid_lft forever preferred_lft forever
inet6 fe80::7cf0:fdb9:c6e7:4cd7/64 scope link stable-privacy
valid_lft forever preferred_lft forever

didier58

C’est bizarre le /26 , malheureusement je ne peux pas vérifier là tout de suite ce point.

Ok pas de problème tiens moi au courant dès que possible pour toi et merci pour ton aide.

didier58

Salut @Ljf,

Je me permets de te relancer as-tu des nouvelles depuis l’autre jour pour l’adresse ip en /26.

didier58

Bien que je ne comprend pas ça à l’air “normal” au sens ouù ça marche chez moi comme ça aussi.
Je pense que c’est un bug tout de même mais qui n’est pas lié à ton soucis (enfin ça reste à prouver).
En l’état il ne semble pas possible depuis un VPN ARN d’en contacter un autre… par contre le reste du net devrait fonctionner.

Le problème c’est que le reste du net qui est inaccessible à part certain sites comme arn, sans-nuages, korben, etc… Penses-tu que le bug ce résoudra à un moment ou qu’il faudra passer par une réinstallation?
Bon aprem.

didier58

Je me rend compte que j’ai pas demandé de traceroute en IPv4

traceroute -4 wikipedia.org

voila le retour pour le serveur yunohost:
~$ traceroute -4 wikipedia.org
traceroute to wikipedia.org (91.198.174.192), 30 hops max, 60 byte packets
1 vpn-end.arn-fai.net (89.234.141.1) 12.078 ms 11.969 ms 15.372 ms
2 hwhost-2.arn-fai.net (89.234.141.132) 16.616 ms 16.583 ms 16.531 ms
3 gi0-6-0-19.203.rcr21.sxb01.atlas.cogentco.com (149.11.26.41) 16.450 ms 16.410 ms 16.337 ms
4 be3548.ccr42.fra03.atlas.cogentco.com (154.54.59.133) 19.119 ms be3546.ccr41.fra03.atlas.cogentco.com (154.54.59.33) 19.205 ms be3548.ccr42.fra03.atlas.cogentco.com (154.54.59.133) 18.886 ms
5 be2846.rcr22.fra06.atlas.cogentco.com (154.54.37.30) 19.086 ms be2845.rcr22.fra06.atlas.cogentco.com (154.54.56.190) 18.805 ms 18.753 ms
6 149.11.21.218 (149.11.21.218) 56.581 ms * *
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *

Et pour le pc connecté au hotspot:
~ traceroute -4 wikipedia.org
traceroute to wikipedia.org (91.198.174.192), 30 hops max, 60 byte packets
1 _gateway (10.0.242.1) 8.868 ms 8.854 ms 8.755 ms
2 * * *
3 * * *
4 * * *
5 * * *
6 * * *
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *

didier58