Probleme avec la mise à jour systeme

Bonjour @ tous,

problème avec les mises à jours.

Matériel:
Brique internet lime1.

Systeme:
yunohost
3.6.5.2 (now)
yunohost-admin
3.6.5 (stable)
moulinette
3.6.4.1 (stable)
ssowat
3.6.4 (stable)

Accès interface web et ssh.

Mise à jour avec interface web retour obtenu:

Fetching available upgrades for system packages…

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://repo.mongodb.org/apt/debian jessie/mongodb-org/3.2 Release: The following signatures were invalid: EXPKEYSIG D68FA50FEA312927 MongoDB 3.2 Release Signing Key

W: GPG error: https://packages.sury.org/php stretch InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743

E: The repository ‘https://packages.sury.org/php stretch InRelease’ is not signed.

sources.list.d/grafana_stable.list:deb https://packages.grafana.com/oss/deb stable main
sources.list.d/mongodb-org-3.2.list:deb http://repo.mongodb.org/apt/debian jessie/mongodb-org/3.2 main
sources.list.d/sury.list:deb https://packages.sury.org/php/ stretch main
sources.list.d/yunohost.list:deb http://forge.yunohost.org/debian/ stretch stable
sources.list:deb http://security.debian.org/ stretch/updates main contrib non-free
sources.list:deb http://ftp.fr.debian.org/debian stretch main contrib non-free
Unable to update the cache of APT (Debian’s package manager). Here is a dump of the sources.list lines which might help to identify problematic lines :

et en ssh:

root@didiercl:/home/admin# apt-get update
Atteint:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:3 http://forge.yunohost.org/debian stretch InRelease
Ign:4 http://repo.mongodb.org/apt/debian jessie/mongodb-org/3.2 InRelease
Atteint:5 http://ftp.fr.debian.org/debian stretch Release
Atteint:6 http://repo.mongodb.org/apt/debian jessie/mongodb-org/3.2 Release
Réception de:7 https://packages.sury.org/php stretch InRelease [6 760 B]
Atteint:8 https://packages.grafana.com/oss/deb stable InRelease
Err:10 http://repo.mongodb.org/apt/debian jessie/mongodb-org/3.2 Release.gpg
Les signatures suivantes ne sont pas valables : EXPKEYSIG D68FA50FEA312927 MongoDB 3.2 Release Signing Key packaging@mongodb.com
Ign:7 https://packages.sury.org/php stretch InRelease
6 760 o réceptionnés en 7s (961 o/s)
Lecture des listes de paquets… Fait
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://repo.mongodb.org/apt/debian jessie/mongodb-org/3.2 Release: Les signatures suivantes ne sont pas valables : EXPKEYSIG D68FA50FEA312927 MongoDB 3.2 Release Signing Key packaging@mongodb.com
W: Erreur de GPG : https://packages.sury.org/php stretch InRelease : Les signatures suivantes n’ont pas pu être vérifiées car la clé publique n’est pas disponible : NO_PUBKEY B188E2B695BD4743
W: The repository ‘https://packages.sury.org/php stretch InRelease’ is not signed.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Impossible de récupérer http://repo.mongodb.org/apt/debian/dists/jessie/mongodb-org/3.2/Release.gpg Les signatures suivantes ne sont pas valables : EXPKEYSIG D68FA50FEA312927 MongoDB 3.2 Release Signing Key packaging@mongodb.com
W: Le téléchargement de quelques fichiers d’index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

donc pas possible de faire les mises à jours.

Quelqu’un a une idée merci d’avance pour vos suggestions.

didier58

Salut,

a mon avis la source du probleme est le vieux repo MongoDB (j’ai vu cette erreur apparaitre sur d’autres machines recemmnent car la clef a expirer)

A mon avis tu peux : rm /etc/apt/sources.list.d/mongodb-org-3.2.list

Salut Aleks,

après application de la commende rm que tu m’as indiqué et essai de la mise à jour
avec l’interface web voici le retour:

Fetching available upgrades for system packages…

W: GPG error: https://packages.sury.org/php stretch InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743

E: The repository ‘https://packages.sury.org/php stretch InRelease’ is not signed.

sources.list.d/grafana_stable.list:deb https://packages.grafana.com/oss/deb stable main
sources.list.d/sury.list:deb https://packages.sury.org/php/ stretch main
sources.list.d/yunohost.list:deb http://forge.yunohost.org/debian/ stretch stable
sources.list:deb http://security.debian.org/ stretch/updates main contrib non-free
sources.list:deb http://ftp.fr.debian.org/debian stretch main contrib non-free
Unable to update the cache of APT (Debian’s package manager). Here is a dump of the sources.list lines which might help to identify problematic lines :

et system update reste bleu et rien ne ce passe.

didier58

Hmoké, tu peux retenter après un 'wget -O /etc/apt/trusted.gpg.d/sury.gpg https://packages.sury.org/php/apt.gpg' ?

Salut Aleks,

tout à l’air de marcher les mises à jour ce fond à nouveau mais à la fin dans le bandeau de progression il y a ceci qui s’affiche:

The yaml metadata file associated with logs is corrupted: ‘/var/log/yunohost/categories/operation/20191017-201941-app_install-archivist.yml
Error: Corrupted yaml read from /var/log/yunohost/categories/operation/20191017-201941-app_install-archivist.yml (reason: expected ‘’, but found ‘’
in “”, line 1, column 13:
’a’’r’******’g’
^)’

The yaml metadata file associated with logs is corrupted: ‘/var/log/yunohost/categories/operation/20191017-202012-app_install-archivist.yml
Error: Corrupted yaml read from /var/log/yunohost/categories/operation/20191017-202012-app_install-archivist.yml (reason: expected ‘’, but found ‘’
in “”, line 1, column 13:
’a’’r’******’g’
^)’

The yaml metadata file associated with logs is corrupted: ‘/var/log/yunohost/categories/operation/20191017-202346-app_install-archivist.yml
Error: Corrupted yaml read from /var/log/yunohost/categories/operation/20191017-202346-app_install-archivist.yml (reason: expected ‘’, but found ‘’
in “”, line 1, column 13:
’a’’r’******’g’
^)’
Je ne vois pas très bien à quoi cela fait référence.

A tu par hasard une idée.

Bonne journée.

didier58

Salut,

désolé pour cette erreur, ça a déjà été discuté plusieurs fois sur le forum et en gros: 1) ce n’est pas grave, 2) les warnings vont finir par disparaître après quelques jours

Salut Aleks,

Je suis de retour tous les problèmes sont bien résolus encore merci pour ton aide et tes conseils bon dimanche.

didier58

1 Like