Problème autodiscover

Mon serveur YunoHost

Matériel: VM Proxmox
Version de YunoHost: 4.2.5.3
J’ai accès à mon serveur : En SSH/Webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : oui
Si oui, expliquer: La VM est hébergée à la maison. Pour protéger mon IP publique (et parce qu’elle est dynamique), j’ai un tunnel VPN qui me sert de passerelle. Tout le trafic sortant par sur celui-ci et tout le trafic entrant arrive de celui-ci.

Description du problème

Je ne suis pas en mesure de configurer un compte ActiveSync sur mon smartphone. J’ai installé z-push via le webadmin. J’arrive à joindre /Microsoft-Server-ActiveSync/ sans problèmes.
En revanche, j’ai été obligé de modifier le paramètre : “define(‘USE_FULLEMAIL_FOR_LOGIN’, false);” dans z-push car j’obtenais l’erreur suivante dans autodiscover.log

B08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] -------- Start ZPushAutodiscover
08/06/2021 20:49:32 [ 7787] [ INFO] [#unknown] Z-Push version=‘GIT’
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] Including backend file: ‘/var/www/z-push/backend/imap/imap.php’
08/06/2021 20:49:32 [ 7787] [ INFO] [#unknown] BackendIMAP(): Using UTF-8 as Default Charset for Searches
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] Including backend file: ‘/var/www/z-push/backend/caldav/caldav.php’
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] Including backend file: ‘/var/www/z-push/backend/carddav/carddav.php’
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] Combined 3 backends loaded.
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] ZPushAutodiscover->login(): Using the complete email address for login: ‘adrn@ux.me’
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] Combined->Logon(‘adrn@ux.me’, ‘’,***))
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] BackendIMAP->Logon(): User ‘adrn@ux.me’ is authenticated on ‘{localhost:993/imap/ssl/novalidate-cert}’
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] BackendCalDAV->Logon(): User ‘adrn@ux.me’ is authenticated on CalDAV 'https://ux.me:443/cloud/remote.php/dav/calendar$
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] BackendCardDAV->Logon(): User ‘adrn@ux.me’ is authenticated on 'ux.me:443/cloud/remote.php/dav/addressbooks/u$
08/06/2021 20:49:32 [ 7787] [FATAL] [#unknown] Exception: (Exception) - Woops, something’s gone wrong! The CardDAV server returned the http status code 404.
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] ZPushAutodiscover->sendResponse() sending response…
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] ZPushAutodiscover->sendResponse() response sent.
08/06/2021 20:49:32 [ 7787] [DEBUG] [#unknown] -------- End ZPushAutodiscover

Une fois à false, j’obtiens :

08/06/2021 20:50:26 [ 7840] [DEBUG] [#unknown] -------- Start ZPushAutodiscover
08/06/2021 20:50:26 [ 7840] [ INFO] [#unknown] Z-Push version=‘GIT’
08/06/2021 20:50:26 [ 7840] [DEBUG] [#unknown] Including backend file: ‘/var/www/z-push/backend/imap/imap.php’
08/06/2021 20:50:26 [ 7840] [ INFO] [#unknown] BackendIMAP(): Using UTF-8 as Default Charset for Searches
08/06/2021 20:50:26 [ 7840] [DEBUG] [#unknown] Including backend file: ‘/var/www/z-push/backend/caldav/caldav.php’
08/06/2021 20:50:26 [ 7840] [DEBUG] [#unknown] Including backend file: ‘/var/www/z-push/backend/carddav/carddav.php’
08/06/2021 20:50:26 [ 7840] [DEBUG] [#unknown] Combined 3 backends loaded.
08/06/2021 20:50:26 [ 7840] [DEBUG] [#unknown] ZPushAutodiscover->login(): Using the username only for login: ‘adrn’
08/06/2021 20:50:26 [ 7840] [DEBUG] [#unknown] Combined->Logon(‘adrn’, ‘’,***))
08/06/2021 20:50:26 [ 7840] [DEBUG] [#unknown] BackendIMAP->Logon(): User ‘adrn’ is authenticated on ‘{localhost:993/imap/ssl/novalidate-cert}’
08/06/2021 20:50:27 [ 7840] [DEBUG] [#unknown] BackendCalDAV->Logon(): User ‘adrn’ is authenticated on CalDAV ‘https://ux.me:443/cloud/remote.php/dav/calendars/adrien/
08/06/2021 20:50:27 [ 7840] [DEBUG] [#unknown] BackendCardDAV->Logon(): User ‘adrn’ is authenticated on 'https://ux.me:443/cloud/remote.php/dav/addressbooks/users/adrien$
08/06/2021 20:50:27 [ 7840] [DEBUG] [#unknown] BackendCardDAV::discoverAddressbooks() Found addressbook 'oux.me is for sale
08/06/2021 20:50:27 [ 7840] [DEBUG] [#unknown] BackendCardDAV::discoverAddressbooks() Found addressbook 'https://ux.me:443/cloud/remote.php/dav/addressbooks/users/adrien/z$
08/06/2021 20:50:27 [ 7840] [DEBUG] [#unknown] Combined->Logon() success
08/06/2021 20:50:27 [ 7840] [DEBUG] [#unknown] ZPushAutodiscover->login() successfull with ‘adrn’ as the username.
08/06/2021 20:50:27 [ 7840] [ INFO] [#unknown] ZPushAutodiscover->createResponse(): server URL: ‘https://ux.me/Microsoft-Server-ActiveSync
08/06/2021 20:50:27 [ 7840] [DEBUG] [#unknown] ZPushAutodiscover->sendResponse() sending response…
08/06/2021 20:50:27 [ 7840] [DEBUG] [#unknown] ZPushAutodiscover->sendResponse() response sent.
08/06/2021 20:50:27 [ 7840] [DEBUG] [#unknown] -------- End ZPushAutodiscover

A première vue, tout se passe bien. Il s’identifie bien sur caldav/cardav et sur le serveur IMAP. Mais côté smartphone, rien. L’appli Gmail boucle sur la config (mdp, user, serveur, port).
Je ne vois aucune authentification arriver dans auth.log ou mail.log.
En configurant un compte IMAP, aucun souci je synchronise bien.

Je n’ai rien trouvé à ce sujet : il y aurait d’autres paramètres à adapter dans z-push ?

Merci pour votre aide