Problem with domain permissions while updating Synapse

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.11.3 (stable).
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: synapse 1.105.1~ynh1

Description of my issue

I tried to update my synapse from 1.104.0~ynh1 to 1.105.1~ynh1.
This fails, with the message Failed to update permissions : This URL is not available or is used by an installed application followed with a list of my other YNH Apps / URLs / …

I’d expect synapse only to need the server main domain / URL.

My default application for my domain root is my CMS grav, installed under /grav.
Until my last attempt to update synapse this (Synapse and Grav) worked perfectly together.

When I now open my domain root in a webbrowser this redirect to grav is broken and it only says: This is where Synapse is installed.
I tried to app_make_not_default grav and upgrade synapse, but this doesn’t work, too. Same when I made synapse the default. So I reverted grav to be default, but still it doesn’t show up in my browser (when I call domain root) and still says: This is where Synapse is installed. and the redirect to grav remains broken.
This also is true for incognito mode and a second browser, so it’s not a browser cache issue.

My synapse upgrade log is https://paste.yunohost.org/raw/vewohubonu

Thanks a lot for any hints,
Christian

Hello,

I think you had this following issue: Synapse now require to be alone on the domain · Issue #443 · YunoHost-Apps/synapse_ynh · GitHub

Thank you!

That was easy, when you know what to do. :+1:
I only followed your guide to change matrix subdomain and then added the redirect to the old domain, and that it was. :+1:

The only thing I didn’t understand was the ssowat config (why is it neccessary, what does it do?), but I changed it, too.

Thanks A LOT!
Christian