Problem wih PHP apps after migration to Stretch/problème avec les applis PHP après migration vers Stretch

English version
PHP version has changed from php5 in Debian Jessie to php7.0 in Debian Stretch.
When I try to upgrade apps like Dokuwiki or Nextcloud, it says that it can’t reload php5-fpm service.
Problem is, php5 package doesn’t exist anymore in Stretch repository.

SOLUTION:

Remove old php5 packages:
apt remove --purge php5*

Install php7 package:
apt install php7.0

Enable php7.0-fpm service:
systemctl enable php7.0-fpm

Start php7.0-fpm service:
systemctl start php7.0-fpm

Now you can reinstall apps

Version française

La version de PHP a changé et est passé de php5 dans Debian Jessie à php7 dans Debian Stretch.
Quand j’essaie de mettre à jour mes applications comme Dokuwiki ou Nextcloud, une erreur survient indiquant qu’il ne peut redémarrer le service php5-fpm et provoque la désinstallation de l’application.
Le problème vient du fait que le paquet php5 n’existe plus dans les dépôts de Stretch.

SOLUTION:

Supprimer les vieux paquets php5:
apt remove --purge php5*

Installer le paquet php7:
apt install php7.0

Activer le service php7.0-fpm:
systemctl enable php7.0-fpm

Démarrer le service:
systemctl start php7.0-fpm

Maintenant, vous pouvez réinstaller vos applications.

You should not have to do this … if you had to, that probably because there’s a bigger issue. Have you checked that the migration ended up correctly and that you are indeed in YunoHost 3.0.x ?

Yes, everything ended up correctly.