Problem while installing nextcloud

nextcloud

#1

Version française plus bas.

My YunoHost configuration

**Hardware:**raspberry pi
Internet access: ethernet at home
YunoHost version: last one

Description of my problem #en

While trying to install Nextcloud, I got an error and everything is removed. Can’t find any logs so I need help :confused: You’ll find what I could get at the end of the ticket.
I tried to install it with chrome browser.

description du problème #fr

J’ai essayé d’installé nextcloud sans succès sans trouver de log intelligible. La seule chose que j’ai réussi a récupérer c’est ce qui est afficher a l’écran. J’ai essayé de l’installer par google chrome
Merci d’avance pour l’aide

Log Displayed

removing database nextcloud

!!

nextcloud’s script has encountered an error. Its execution was cancelled.

!!

Unable to install Nextcloud

2018-12-19 23:47:15 URL:********** [44769940/44769940] -> “app.tar.bz2” [1]

dpkg-preconfigure: unable to re-open stdin:

debconf: falling back to frontend: Teletype

debconf: (This frontend requires a controlling tty.)

debconf: unable to initialize frontend: Readline

debconf: falling back to frontend: Readline

debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)

debconf: unable to initialize frontend: Dialog


#2

Finally I found that logs (find it at the end) I don’t understand how can’t it write in it as rights are ok, and there is enough space.
Finalement j’ai trouvé ces logs . Je ne comprends cependant pas pourquoi il n’arrive pas a écrire dedans vu que les droits semble ok et qu’il y a suffisament de place.

Thank you!
Merci d’avance

##logs : https://paste.yunohost.org/raw/kojurumito

941 DEBUG + sudo -u nextcloud php occ --no-interaction --no-ansi maintenance:install --database mysql --database-name nextcloud --database-user nextcloud --database-pass l5cUzoe8Uem5VTtThWCdypLk --admin-user admin --admin-pass svHYXU --data-dir /home/yunohost.app/nextcloud/data
218949 DEBUG Nextcloud is not installed - only a limited number of commands are available
219272 DEBUG Can’t create or write into the data directory /home/yunohost.app/nextcloud/data
219375 DEBUG + ynh_die ‘Unable to install Nextcloud’
219377 WARNING Unable to install Nextcloud
219379 DEBUG + echo ‘Unable to install Nextcloud’
219381 WARNING !!
219383 DEBUG + exit 1
219384 WARNING nextcloud’s script has encountered an error. Its execution was cancelled.
219386 DEBUG + ynh_exit_properly
219388 WARNING !!
219390 DEBUG + local exit_code=1
219391 WARNING


[Official app] Nextcloud
#3

yeah, even iam facing exactly the same issue… tried multiple times, but same error…


#4

Hmm, very weird… what umask returns, when executed as root?


#5

image


#6

When you say the rights are ok, can you execute: sudo -u nextcloud touch /home/yunohost.app/nextcloud/data/test ?


#7

I can’t do -u nextcloud as the installation fail the installation script remove the user.


#8

Got a similar problem, it turns out I had to manually install php7.0-zip (installer seems to check for php-zip, which doesn’t work)

As a sidenote, I noticed the /home/yunohost.app/nextcloud directory is not removed when the installation first fails, with owner/group set to 996 (in my case).
If another user is created after the first failed nextcloud install, the next attempts might fail: nextcloud user would get a different UID, hence not being able to write to its directory anymore.

(EDIT: this occurred on a dedicated server running Debian Stretch)


#9

didn’t work for me :confused:
I reinstall all my yunohost and the error is different this time.

Happy new year! :slight_smile: