Problem Display Nextcloud - Files no more displayed

My YunoHost server

My YunoHost server

Hardware: Beelink U59
YunoHost version: 4.3.6.3 (stable)
**I have access to my server : Through SSH & through the webadmin & direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes, runing backports package because my GPU is not available with Debian 10, so I upgraded kernel of linux in 5.X Backports and forced it in the grub to launch the GPU pilots.
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen |

Description of my issue

Hello Everyone,

Since a while, I have problem to display my data on nextcloud with Yunohost. At first, my files were no longer displayed even if the architecture of yunohost seemed to work well. In the center part of my screen, no files were displayed.

Since the last update, my complete displayed of the nextcloud app is break. Here is a capture :

To solve this prolem, I already tried different things regarding those topic :

The main trouble seems to come from the occ. From the beginning I have problem to run manually OCC command. It seems that the whole system could not execut those function properly :

The problem persist :
When trying to run an OCC command :
Could not open input file: occ
I tried this : sudo -u www-data php --define apc.enable_cli=1 /var/www/nextcloud/occ maintenance:repair
It returns:

Cannot write into "config" directory!
This can usually be fixed by giving the webserver write access to the config directory.
But, if you prefer to keep config.php file read only, set the option "config_is_read_only" to true in it.

Tried this too : `
/var/www/nextcloud/config# chown -R www-data:www-data config.php
But still, I got this when i tried to rescan files :

sudo -u www-data php occ files:scan --all
An unhandled exception has been thrown:
OC\HintException: [0]: Memcache \OC\Memcache\APCu not available for local cache (Is the matching PHP module installed and enabled?)

Seems to come from the PHP ?

But at this point, I am asking myself if it would not be more easy to reinstall completly the app. The point is that i woudlike to not loose my data and also recover the users data as it was. Hopefully the date is hold on an external nas which mount locally on the debian.

So I reach you in order to answer two questions :

  1. Do you have any idea from when come the problem and how to solve it ? I do no know from where to start to investigate actually …
  2. Should I reinstall the app ?

Once again, thanks a lot in advance to the comunity for your help,
I will be reactiv to answer if my message is not clear.

Good day,

Do not forget to have php --define apc.enable_cli=1 in the command line.


Let’s try to reset your permissions and so on, by force-upgrading the app:

sudo yunohost app upgrade nextcloud -F

Then report if that fixes your issue. (most likely not, but then we have a sane base to work on :slight_smile: )

Hi @tituspijean

Thanks a lot for your answer. So before to start, I just went to check the app which was displaying the internal server error page (without bug on display).

I tried this but my ssh command seems to block on it, it turns for minutes and I have to close my SSH client… Is it done or not ? Do not know …

I then upgrade and I recover my displays :

Not fixed but as you said, at least we can work on now ^^

Thanks a lot, I keep searching for a solution !

Scans can take a looooong time indeed. Maybe there’s a --debug flag or something to see what’s happening.

As for your actual issue, I will try to have a look into it tomorrow.

Meanwhile, can you share your NGINX and PHP logs?

Thanks @tituspijean

I tried the debug and got this

php --define --debug apc.enable_cli=1
Could not open input file: apc.enable_cli=1

And the command stop to run normally, this is strange that it turns endless without the debug keyword, I will go to see until tomorrow if I find an explanation about ^^

Thanks a lot for tmr, I will share with you this tonight

First, check the php version you need: sudo cat /etc/yunohost/apps/nextcloud/settings.yml | grep phpversion

In my case I get phpversion: '7.4' so I put php7.4 in the following command. --debug is actually -v (or -vv or -vvv depending on how verbose you want the command)

cd /var/www/nextcloud
sudo -u nextcloud php7.4 --define apc.enable_cli=1 occ files:scan -vv --all

Thanks dear @tituspijean,

I follow :

Got this : phpversion: '7.3'
Strange no ? Php 7.3 is deprecated I think

Run this : sudo -u nextcloud php7.3 --define apc.enable_cli=1 occ files:scan -vv --all
And it works! I mean, it rescan all the files, except some in red but nothing big!
image

Now here is the nginx logs :
NB: I am actually only using the dynamicslights.ovh domain
https://paste.yunohost.org/heguzopezi

And here is the PHP Logs:
https://paste.yunohost.org/delogoqute

In any case thanks a lot for the help!

Mmmh, I don’t see much in there that would be helpful.

Can you open your browser’s debug panel (F12), and share the errors in the Console?

Hi @tituspijean

Here is what I get when loading the home page in the console (F12):
https://paste.yunohost.org/obuseziwod.sql

Hello Everyone,

I am still searching or a solution, my nextcloud is still colpletly bocked !
Should I reinstal it from scratch ?

Thanks in advance,