Point Nextcloud office app to correct subdomain

:uk:/:us: Message template (english)

My YunoHost server

Hardware: Old laptop or computer – Lenovo ThinkCentre Tiny

YunoHost version: (stable)

I have access to my server : Through SSH & through the webadmin

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

If yes, please explain:

If your request is related to an app, specify its name and version: Collabora

Description of my issue

I successfully installed Collabora but, stupidly, did so on my TLD, which blocked installation of other apps on that domain.

I shutdown Collabora and uninstalled/reinstalled it on to a sub-domain. Installation was successful with one warning – I had to reload coolwsd.

The problem is that my documents aren’t loading, because the Nextcloud app is still looking for them at https://domain.uk, instead of at https://docsi.domain.uk. In the administrations setting of Nextcloud, the domain is displayed but can’t be modified, as in the picture below.

How can I modify the address that the Nextcloud office app points to, please? I can’t find anything in the Collabora settings. Thanks as always.


Mon serveur YunoHost

Matériel: Vieux portable ou ordinateur - Lenovo ThinkCentre Tiny

YunoHost version: (stable)

J’ai accès à mon serveur : Via SSH & via le webadmin

**Etes-vous dans un contexte particulier ou avez-vous effectué des réglages particuliers sur votre instance YunoHost ? ** : non

Si oui, expliquez :

Si votre demande concerne une application, précisez son nom et sa version : Collabora

Description de mon problème

J’ai réussi à installer Collabora mais, bêtement, je l’ai fait sur mon TLD, ce qui a bloqué l’installation d’autres applications sur ce domaine.

J’ai arrêté Collabora et je l’ai désinstallé/réinstallé sur un sous-domaine. L’installation s’est déroulée avec succès avec un seul avertissement - j’ai dû recharger coolwsd.

Le problème est que mes documents ne se chargent pas, parce que l’application Nextcloud les cherche toujours à https://domain.uk, au lieu de https://docsi.domain.uk. Dans les paramètres d’administration de Nextcloud, le domaine est affiché mais ne peut pas être modifié, comme dans l’image ci-dessous.

Comment puis-je modifier l’adresse vers laquelle l’application Nextcloud office pointe, s’il vous plaît ? Je ne trouve rien dans les paramètres de Collabora. Merci beaucoup.

Traduit avec DeepL.com (version gratuite)

I have had a reply to this issue on the Nextcloud Forums. The inability to adjust settings via the GUI, particularly in relation to wopi details, is a known issue.

The command line solution requires employing occ, Nextcloud’s own command line. Unfortunately, I am struggling to apply occ commands in Yunohost. I have found this forum topic [SOLVED] Using OCC command on Nextcloud and a blog article on the subject: OCC Nextcloud Command in Yunohost – WONKO.NET I have got in to occ, but am not able to get the config file to actually open. I have posted a full description of my struggles here: How do I point Nextcloud Office app at a differnte URL? - #3 by danceswithcats - office - Nextcloud community

I will update on my progress.

sudo yunohost app shell nextcloud


php8.2 --define apc.enable_cli=1 occ COMMAND

Replace COMMAND with what you need

1 Like

Thank you @jarod5001

I wonder whether you could help me with the syntax of my command. I did

php8.2 --define apc.enable_cli=1 occ config:app:set --value ${https://docsi.DOMAIN.uk} richdocuments wopi_url

and got the response:

Not enough arguments (missing: "name").  

config:app:set [--output [OUTPUT]] [--value VALUE] [--update-only] [--] <app> <name>

occ config:app:set richdocuments public_wopi_url --value https://office domain.com

Thanks so much @jarod5001 That’s done it. Thank you, thank you, thank you.

Very well done.


Merci beaucoup @jarod5001 C’est fait. Merci, merci, merci.

Très bien fait.

Sorted with generous help from @jarod5001 here and some people on the Nextcloud forum.

Full solution:

sudo yunohost app shell nextcloud

This produces a readout of all the nextcloud settings as they stand.


php8.2 --define apc.enable_cli=1 occ config:app:set --value="https://docsi.domain.com" richdocuments wopi_url

Output from that:

Config value wopi_url for app richdocuments set to https://docsi.domain.com

When I looked at the Office page in the administration settings of Nextcloud UI, the correct domain was displayed and a green tick showed that the Collabora server was reachable. My documents opened. Joy was unconfined.


Réglé avec l’aide généreuse de plusieurs personnes ici et sur le forum de Yunohost.

Solution complète :

sudo yunohost app shell nextcloud

Cela produit une lecture de tous les paramètres nextcloud tels qu’ils sont.

Ensuite :

php8.2 --define apc.enable_cli=1 occ config:app:set --value=“https://docsi.domain.com” richdocuments wopi_url

Ce qui en ressort :

Valeur de configuration wopi_url pour l’application richdocuments fixée à https://docsi.domain.com

Lorsque j’ai regardé la page Office dans les paramètres d’administration de Nextcloud UI, le bon domaine était affiché et une coche verte montrait que le serveur Collabora était accessible. Mes documents se sont ouverts. La joie n’était pas limitée.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.