Pleroma - deleting my instance (hypothetically)

Hello :slight_smile: Sorry, another question from me!

I’ve noticed my Yunohost user is hard-baked into my Pleroma instance — in other words, my Yunohost user fred (for example) was designated as the administrator of Pleroma when I installed the app, so now fred is the administrator of a Pleroma instance at https://example.tld/users/fred.

My instance is just for me, so if I decide to delete it then there are no other users on the instance for it to affect. However, I’d want the ‘delete’ signal to be sent across the Fediverse if I did delete my account, so all my connected friends and their feeds will stop seeing my profile and it will be gone from the Fediverse. Otherwise my account will stay there indefinitely, in theory.

In learning how to set my instance up, I encountered some trouble and wanted to delete it and re-install. I noticed that going into Settings (the cog in the top-right) > Security > Delete Account, entering my password and selecting ‘Delete Account’ doesn’t work — it says there’s a problem with authenticating my password and that I should contact the administrator. But I am the administrator, and I can’t delete myself in Admin FE > Users, as the option to delete myself isn’t given.

I also noticed that uninstalling the app in Yunohost did not remove my profile from the Fediverse — viewing from Mastodon it was still present, but selecting to ‘View original page’ took me to my Yunohost login screen.

Is there any way to delete my Pleroma account so that the ‘delete’ signal is sent out, and so that my instance vanishes from the Fediverse?
(I’m asking theoretically — I’ve only just set it up!)

Thank you :slight_smile:

1 Like

Also, somewhat linked to this — I’ve noticed that when I try to change my password, it tells me that it’s worked and that my password is now different. It then logs me out, but I cannot use my new password to log in. I have to use my old one, and even forcing a password reset via Admin FE does not solve the issue — my old password remains in use.
I haven’t yet tried enabling two-factor authentication (2FA) but a part of me is reluctant to do so if doing a simple password reset encounters problems. :confused:

In response to this, the pleroma_ynh github repo has an open issue about logging in to your account. A comment lower down the thread says that the issues with passwords – affecting password changes and deletion of profiles – only happen if you’re logged in to the Yunohost portal at the same time, and that logging out of there resolves them. I have yet to test this.

In case anyone’s interested, I’ve also found – separately – that:

  • Uploading an image as an attachment to a status while it’s being written, not posting the status, is what uploads the image to your uploads directory.
  • The image filename is hashed by default (so cat-and-dog.png gets uploaded as a ~30-character string of gibberish that ends in .png).
  • If the status is deleted, whether it’s posted or not, the image file stays in uploads.
  • Manually deleting the image file from uploads is possible, but made 1000x times harder by the fact the filename is hashed, so if you have lots of images in there, the date & time it was uploaded are all you can use to single it out (e.g. by using sudo ls -altog /path/to/uploads/, which lists everything in date & time order).
    (I run Pleroma on a Raspberry Pi without a screen, SSHing in via my laptop. If I had a GUI and a window system that supported thumbnails, this wouldn’t be so hard.)
  • Pleroma does not have an in-built post expiration feature that tidies your instance for you after x days, unlike Mastodon or Friendica.

I’m mainly just posting these to possibly help other people, not because I’m expecting anything to come of it. Pleroma’s and Yunohost’s documentation leave a lot to be desired, so the more we tell each other, the better.

Pleroma 2.5.0 just released with lot of change…

I will wait for the Yunohost version to be upgraded and will try again. I’m not sure that the changes in the new Pleroma version will address these issues, but it seems quite major so I’m still interested to see what’s different.

I uninstalled Pleroma, then:

  • installed Friendica
  • created an admin account and a user account for myself, as a test, using different email addresses from my Pleroma account, but the user account had the same username; this overwrote the content from my Pleroma account with that of my Friendica account;
  • uninstalled Friendica
  • reinstalled Pleroma

… then found I couldn’t create an account with my previous (Pleroma) email address because “a user with this email address already exists”, even though it had been uninstalled and reinstalled.

Is there a cache somewhere I have to clear, or is Pleroma remembering me “externally” somehow?

When you delate an user account in Pleroma, the email and the username stay in DB (at least on an install with YNH)… I don’t know if it’s intentional or a bug.

Discovered this few days ago :face_with_spiral_eyes:

It does this with Friendica too, and maybe Epicyon, but I haven’t yet figured out whether they stay in the DB permanently, is on a timer (Friendica says it takes 7 days for an account to be deleted but this may require the software to stay on your server for that long, I don’t know) or involves some kind of interaction with the rest of the Fediverse to spread the deletion request to other servers.
With Epicyon I’ve had more luck, in that it genuinely seems to forget who I am if I delete my account, then reinstall the software. However, none of the graphical changes I make to my profile stick, with banner images, avatars and logos not showing at all when I upload them. Textual changes stay, but not graphical ones.

Update: The issue with authenticating passwords happens on Pleroma regardless of whether you’re logged in to the Yunohost portal or not. I tried it a couple of days ago and could not delete my account via the settings UI (it said there was an authentication error again) or change my password (it would say ‘success’, log me out, but still require my old password to log me in, nothing had changed). Attempting a password reset via Admin FE to get a password reset token did the same - logged me out, but changed nothing.

I’ve given up on trying to self-host my own federated social media server now. Either you have to have extensive sysadmin experience to figure it all out for yourself (because generally the documentation is either far too in-depth, or vague, or sparsely written, or doesn’t exist), or Yunohost packages them so differently from the stock builds that the original documentation becomes almost useless.
It undermines the whole “everyone should self-host” ethos. The way things have been built, I don’t feel I’ve been enabled to do so.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.