Pixelfed : Profils et Pages des publications vides après upgrade

#1

Mon serveur YunoHost

Matériel: Kimsufi KS-3 / Intel Atom N2800 1,86GHz / 4Go DDR3 1066 MHz
Version de YunoHost: 3.5.2.2
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifications particulières sur votre instance ? : non

Description du problème

Bonjour tout le monde,

Bon, c’est un peu le topic du dernier espoir. Après avoir demandé sur le Github du package et sur celui du projet, je tente ici.

Pour vous expliquer le problème : J’ai actuellement la version 0.8.6 de Pixelfed. J’aimerai tout naturellement upgrader vers la dernière version dispo sur YunoHost qui est là 0.9
Seulement dès que je le fais, les profils ne se chargent plus (seulement le header et le footer) et les publications non plus.
Malgré tout, les pages home / public timeline / découverte marchent parfaitement !

Si vous avez des idées, je suis preneur. Sinon je reprend mon instance à zéro, mais je commence à avoir quelques inscrits dessus et je trouverai ça dommage :anguished:

Un exemple de profil “cassé” : https://pixelfed.fr/julienlecomte

#2

Bon !

Par une manœuvre ultra périlleuse j’ai réussi à faire quelque chose.

  • J’ai donc installé une version clean sur un deuxième serveur.
  • J’ai upgradé mon instance principale, avec le bug d’affichage donc.
  • J’ai remplacé tous les fichiers de mon instance principale par la clean install. Sauf le .env et le dossier storage.

Ça marche. On va dire que c’est résolu, même si ça me parait bien bricolé :face_with_raised_eyebrow:

1 Like