[Pixelfed] Pictures not loading

Ok I can reproduce the issue, since the upgrade to v0.11.5.

I don’t know what’s happening.

1 Like

I submitted a bug report Picture display (?) broken after upgrade to v0.11.5 · Issue #4275 · pixelfed/pixelfed · GitHub

1 Like

seeing this issue as well. an interesting note: i uploaded an avatar, and that worked just fine.

if there are things you would like us to try, or information that could help, let us know.

edit: as of this morning it is reported as fixed: Picture display (?) broken after upgrade to v0.11.5 · Issue #4275 · pixelfed/pixelfed · GitHub

Yes the fix as landed upstream, we need to update Yunohost package accordingly.
Some tests started here : Testing : v0.11.5 by lapineige · Pull Request #205 · YunoHost-Apps/pixelfed_ynh · GitHub

1 Like

any update?

It needs testers Testing : fix 0.11.5 media/s3/… by lapineige · Pull Request #210 · YunoHost-Apps/pixelfed_ynh · GitHub
In particular for the newly uploaded image issue, in my case it doesn’t fix it, I need more feedback to understand better that issue.

Apologies for the newbie question, but what URL do I used to install the new version to test? I should have some time to give it a shot.

I was reading about the file permissions as well. I updated the filesystems.php with that portion of the patch yesterday, but there was no change to the display (it did look like some of the folder permissions changed…)

You don’t have to apology for anything, I should have included it :slight_smile:

It’s this URL : GitHub - YunoHost-Apps/pixelfed_ynh at testing (on github, you right click on the branch name (the one on the right), it’s that link)

Hence: yunohost app upgrade pixelfed -u https://github.com/YunoHost-Apps/pixelfed_ynh/tree/testing

Did you run the php artisan commands ?

1 Like

i did run the artisan commands, and even deleted the ‘m’ folder as one of the other github comment suggested just to try.

will update and see how things go (probably in the morning at this point)

I have had the same issue since the 11.5 update. I applied the testing branch upgrade, ran the two artisan commands, still no uploads working at webmink shared a post

I did find that in filesystems.php the new permissions section had not been added, so I do wonder if the upgrade completed successfully. I added it manually, made no difference.

I ran the update, did the artisan commands. The artisan media:fix-nonlocal-driver gave me an error. So I still gave uploading pictures a try and nothing had changed.

So I looked at the commit talked about in the github thread and opened up some of the files, but did not see the changes.

I reran the update script but it said update had happened. is it possible the patches aren’t getting applied, which is causing the continued issue?

I had the same !

I did it again, it worked.

You can force it with --force.

I don’t understand why files are not changed. I wonder if it’s because we use a commit number and not a main release.
This is way too strange that multiple people see no change after the upgrade.

I did it again (with -F) and no change unfortunately.

I also get

Warning: fatal: not a git repository (or any of the parent directories): .git

in the middle of the upgrade each time, although the process seems otherwise to complete OK.

That’s something very significant. We need to investigate that… this upgrade seems to fail :thinking:

That’s normal and not a problem.

I just saw Pixelfed had a new release (0.11.6), is there a way to test that release and see if that takes? I think you said that this YNH update was only pulling from a commit, so maybe the release will update correctly?

Or, if there are different things you’d like us to try, let us know.

I made the upgrade available for Yunohost this morning :wink: (before your post actually :grin:, but that might have taken some time to be reflected in Yunohost catalog).

On my side it doesn’t solve the issue, sadly :confused:

1 Like

well i am on (0.11.6) still shows No Photo Available
New UI - can upload just says No Photo Available
Old UI - i get oops something went wrong.


I updated and no change with the update. ran the artisan commands just to check. deleted the m folder to get Pixelfed to generate a new one. Even spot checked two files to see if the changes from the previous mentioned commit were there, and they were.

I suspect (as i think you may already) that we have a permissions issue, as I can get it to work with some CHMODing.

I uploaded a new file and the file path is


the file permissions as you go through them look like this:

drwx------ 3 pixelfed pixelfed 4096 May 3 18:13 m
drwx------ 3 pixelfed pixelfed 4096 May 3 18:13 _v2
drwx------ 3 pixelfed pixelfed 4096 May 3 18:13 548602088904634369
drwx------ 3 pixelfed pixelfed 4096 May 3 18:13 c537ce87c-f5971d
drwx------ 2 pixelfed pixelfed 4096 May 3 18:14 6QKPgVfVMjN2
-rw-r--r-- 1 pixelfed pixelfed 1010496 May 3 18:14 PbghbcO2BwIl6WZJhOHUY7OHmNvuHv1bzYk1NxPT.png
-rw-r--r-- 1 pixelfed pixelfed 107350 May 3 18:13 PbghbcO2BwIl6WZJhOHUY7OHmNvuHv1bzYk1NxPT_thumb.png

So it looks like the photos are getting the right permissions (0644) but the folder are not (0700 instead of 0755).

IF you CHMOD all those folders back to the m folder to 0755 the image will load and the post works.


When you upload a new picture, it also creates a new folder to put them in, and that folder is still being created as 0700. I did double check the filesystems.php file and the permissions part is there with the correct numbers.

not sure if any of that helps…

1 Like